Deck view display text not following rules defined in Help?

I’m working on my first view in my first app and I simply can’t get the Deck items to show the two fields I want.

The table behind the view has columns:
_RowNumber - Number
UnitNumber - Number [Key, Label]
ReceivedDate - Date
…~20 more columns of various types: Date, Text, Number, LongText, Yes/No…
(virtual) Related Items - List
(virtual) MyCustomDisplayText - Name

According to this Help topic:


“…Deck view will display two text columns … chosen in the following order: Row Label, Virtual Columns of type Name, Name type columns, key columns, required columns, normal columns in sheet order.”

From that description, I would expect my Deck view to show UnitNumber (Row Label) and MyCustomDisplayText (first Virtual Column of type Name). Instead, it’s showing UnitNumber and ReceivedDate (just the next column after UnitNumber).

What am I doing wrong?

Thank you. -Matt

Those are just the columns that the editor auto-picked for you. In the Deck view’s definition, find this section. The red arrows show where you choose which two columns to show.

2 Likes

Man, how did I miss that? I must have looked through all the View configurations three or four times before giving up and posting here. I think I glossed over these settings because their values were blank and I was looking for something specifying the current fields being displayed. That, combined with that Help topic steering me towards the Data setup. Either way, a bit embarrassing!

This is exactly what I needed. Thank you very much. Glad to find out this setting is here in the View setup and not controlled by Data field setup like I was starting to believe.

2 Likes