Deep link and quick edit activation

I’m trying to use deep link, I’ve filtered like the example below, but I couldn’t activate quick edit, how can I do it?

LINKTOFILTEREDVIEW (“Customers Table View”, AND ([Sales Rep] = [_THISROW]. [Sales Rep Id], [Priority] = High))

Do you have the “Enable QuickEdit” property turned on in the “Customers Table View”?

53%20PM

Assuming you do, when you say “I couldn’t activate quick edit”, does this mean you don’t see the icon to activate it OR when you tap the icon it doesn’t work?

1 Like

no, normal way of quick edit works, no problem. I want to open the deep link filtered table with the quick edit table active

You have to have the the QuickEdit property turned on in the view you are navigating to - “Customers Table View”.


So I threw together a quick test in my app, to filter my Inventory table down to 3 rows. I used the original view which has the QuickEdit turned on. Activating the Filtered version of the view I get this:

43%20PM

Then tapping on the QuickEdit Icon I get the below.

21%20PM

No problem in this way, I want to open the table and open the filtered table without touching the quick edit button

1 Like

Sorry! I’m confused. Are you saying you want to open into QuickEdit automatically?

CONCATENATE("#view=Customers Table View&quickedit=true&row=", ENCODEURL([Sales Rep] = [_THISROW].[Sales Rep Id]))

quick edit automatically opens but filtering doesn’t work

Yeah, that’s exactly what I want.

Got it! I am seeing the same thing as you. I have been trying to dig into the posts to see if anything is there. I very very vaguely recall some mention in a post about Filtered View functionality with DeepLinks but can’t seem to find it.

I guess the question is if there is a Deep Link way to filter rows? Anyone?


I checked here but could not find a solution.

Awesome! Here is a link to a post that might prove very helpful as well:

EDIT: Not as helpful as I had hoped! :frowning:

So In my test, I am using:

CONCATENATE("#view=Inventory&filter=", ENCODEURL(IN([Product Code], LIST(“100001”,“100002”))))

The Expression tester seems to recognize the filtered rows The first two have “filter=Y” while all the rest of the rows have “filter=N”

Yet, when the view is activated I still get ALL rows shown.

I’ll post out the community this part to see what shakes out - I’m curious now!! :slight_smile:

Ok, I don’t know if you have seen my post in the Questions area, but the short of it is that you can’t really do a filtered view using a manual deep link. The next best thing is to submit a Feature Request to add the capability of opening a table in QuickEdit mode.

This was your post originally. Would you like to open that request? I too feel it would be a really useful feature.

I wonder if this would work…

CONCATENATE(
  LINKTOFILTEREDVIEW(
    "Inventory",
    IN([Product Code], LIST(“100001”,“100002”))
  ),
  "&quickedit=true"
)
9 Likes

Your thought it that the function would be preprocessed into its URL and then concatenated with the quickedit parameter. I’ll give it try.

2 Likes

@Pointer

You are a genius!! It worked!!

20%20AM

4 Likes

You are a real professional, thank you very much.

2 Likes

Wow! @Steve

Your expression is indeed is very ingenious.

1 Like

Glad @Steve got it. I was about to suggest the same thing based off what I learned about the force syncing deep link yesterday.

1 Like

I want to ask something about it, can I go back to the previous page, after recording quick edit