Deleted row continues to show in app

Hi there, I had to replace some rows in the Google sheet for my app. I took these steps: 1) delete the old rows, add blank rows at the bottom of the sheet, paste in new data. But when the app synced, some of the old rows still show - example rows below. These rows are no longer in the sheet.

I checked for these issues:

I am not sure what is going on or how to troubleshoot. Rows with those column values don’t exist anymore. Any ideas?

Hi @ml16

You may want to contact Support here:

If this is the view of the App Editor, then I face the same problem repeatedly and the solution in my case is always to reload the browser’s page after the sync, following such change.

2 Likes

Hello @KJS, I suggest you try deleting your browser’s cache and see if that fixes it.

Alternatively, you can try the “Save and verify data” option on the App Editor

image

3 Likes

Hi @Rafael_ANEIC-PY,

Of course the issue is related to browser’s cache, and deleting cache will surely work, but it would be a more brutal solution than a simple page refresh, also with its own inconveniences.

I didn’t know about the “Save & verify data” option, and will surely try it. Thanks much my friend :slight_smile:

Yeah, I agree, the cache has been a real pain in the rear for me lately, I was just about to write a post to rant a bit about it haha.

1 Like

Please do :smiley:

Thanks for the ideas. I had refreshed the browser a million times and cleared the cache, but I did so again and tried the “Save and Verify” and I’ve now located the mysterious rows in the actual Google sheet. So - I am not sure what did it, but I guess problem solved for now. Thanks!

3 Likes

So not an AppSheet problem after all?

2 Likes

Nope, they weren’t there before and they are now, so definitely an AppSheet problem. I am attributing their recovery to “save and verify,” but I guess I can’t say for sure.