Disabling Bot does not disable

I am getting error in BOT - Bot - Send Invoice Report to Accounts has no defined process.
There is a process.

I disabled the BOT thinking this would stop the error and allow the App to sync so my users weren’t getting an error but with the BOT disabled I still get the error and the app won’t sync. I had to delete the BOT to allow users to use the App

1 Like

Attn @prithpal @Dan_Bahir @praveen

1 Like

@Martina its tough to figure out why you were getting the error without looking at the bot definition. Are you able to share a screen shot of the bot?

1 Like

Do by any chance have a workflow with a similar name ?

1 Like

I had to delete the Bot. I made a copy of the App and have the Bot working. Just about to replicate it now in the live App. It wasn’t the error I was concerned about. It was not being able to completly disable a bot like we could with workflows. Disabling a bot doesn’t seem to disable the attached process. I do not have a workflow with same name.

1 Like

Bot now working in live app. If you are creating a bot and get an error which you don’t have time to figure out quickly, need to be able to disable the bot so App syncs and users can use App.

1 Like

That’s weird. You should be able to disable a bot (& the attached process) just like you are able to disable a workflow. Maybe you are running into a bug with some corner case or validation issue.

1 Like

So I created a Test Bot in a Test App. See below of Bot enabled with error and Bot disabled with error

2 Likes

In your bot, it looks like the table(entity) that is being referenced in the event is different from the table(entity) that is being referenced in the process. They need to be the same. Can you please check?

Did you create your bot from scratch through the “+ New Bot” button and configured the event and the process? Or did you create the event/process separately and add that to a bot?

1 Like

I created Bot from scratch. That is a deliberate error I made to cause an error to see if I could disbale the Bot

This error should be explicit. “Incompatible” is ambiguous and not helpful.

They are tables, not entities.

2 Likes

@Moura @jared FYI on the error message

2 Likes

Apart from the actual error, is someone looking into why a bot cannot be disabled.

1 Like

Yep!

3 Likes