Document template time incorrect,

I have a time stamp field which shows up properly on all views in the app. I double checked settings in the google sheet. Local is set to US and am in the correct time zone. However, in one of the workflow actions I have a document template which I created by clicking the “Create” button. The timestamp field (which is correct in the app) shows up incorrectly once the trigger executes and uses the template.
Any help is appreciated or should I contact support@appsheet.com directly?

1 Like

Could you share the screenshots of the relevant part of the document template and the way the said column is configured in the table?

I am sure it is something simple, but I can’t seem to find it.

Please see screen shots attached.

Thank you,

Thank you for the detailed info. I did some testing on an exactly similar setup and I did not get any discrepancy between the app timestamp and the workflow generated PDF.

Someone else may have input for you.

1 Like

Thank you for doing that. I appreciate it.
Not that it matters, but I was using a Google Doc not PDF.
Thanks again.

1 Like

Your are welcome. Yes, I also used Google Doc as template and PDF is output format.

Workflow (Behavior >> Workflow), or report (Behavior >> Reports)?

1 Like

Workflow (Behavior>>Workflow)

I just re-created the template and I still get the same result (4 hr difference) from what the current time is as well as what the google sheet has and the AppSheet record set is.
It has got to be a setting somewhere.
(I guess I can probably create a formula and subtract 4 hrs , but that would be my last resort)
Thanks for helping.

I have no explanation. :frowning: Next step is to engage support@appsheet.com.

1 Like

Thank you for taking a look.

2 Likes