Don't clear data in inputs after clicking Submit

Hello I have the standart input-form with 3 inputs.

On the bottom right there is the button “ПОДТВЕРДИТЬ” (Submit). After entering values into inputs and clicking this button all data appends to the google spreadsheet, and inputs become cleared.

is there a way not to clear data in 2 first inputs after clicking button Submit?
and one more question - where can I turn off synchronization after clicking Submit?

Hi @Dmitriy_Rudakov

Can you be more specific about that ? Do you mean that values just written in the Google Sheets disappear ?

Here:

1 Like

Thank you for sync, I will look))

No, I mean that after clicking on button Submit not to clear data in 2 form inputs. All data perfectly write to sheet))

@Dmitriy_Rudakov

ok.
Actually I think you have an option enabled in your form View options, which is probably currently ticked, unlike above:
image

You need to have in mind that this is a form supposed to get data from user input in order to append a new row to your sheet. Because of this, it’s naturally empty.

If you want it to be pre-filled with previous entry, you may want to use the Initial value expression of each of the fields expected to be pre-filled.
For building the expression for getting the last value previously entered, I suggest you have a look to this excellent thread (almost my bedside book):

More accurately, this post:

3 Likes

thank you for help! where must I put this formula? Sorry, I’m newbe at this))

Hi @Dmitriy_Rudakov

Here:
image

1 Like

I already checked this, but it is nothing displayed.

wrote in auto computed in initial value

LOOKUP(
MAX(
SELECT(
@packing[_ROWNUMBER],
([_THISROW].[login] = [login])
)
),
@packing”,
“_ROWNUMBER”,
“login”
)

Hi @Dmitriy_Rudakov

I think there is a confusion here:

I added this formula here

is it right? I need to show last values in 2 inputs.

1 Like

and no data showed

about sync. Everything is turned off, but synchronization starts after every clicking on Submit…

Seems obvious, but just in case: is there a data to show ?
You can see it with the Test button here:

1 Like

About sync:
did you have a look to the first setting I shown here ?

1 Like

yes, it is turned off too

you have to turn this one on :slight_smile: (as it is in the image I provided)

but look. if I turn on delayed sync, the writing in spreadsheet is stopping to work(((

Actually no.
It will write, but a little slower.
You will know it’s written down as soon as the number in the red circle disappear.

Unless the behavior I’m describing is not the one you see ?

2 Likes

about testing the formula with last value from table. It showes few results

1 Like

but it dissapear and writes to table only when I click on button Sync

image

it can’t write automatically after Submit?

There is a misunderstanding of the Delayed Sync feature.
I suggest you have a look to this documentation:
Section “Delayed sync”

Here is how it behaves on my apps (it’s a GIF - real time behavior, around 30 to 45 secondes on a complex app):
Shared with CloudApp

2 Likes