Edit button in card view

I have an edit button that shows on one of my card views.

I found similar posts that stated if you go to behavior…actions…appearance and set the prominence to do not display, then the edit button would not be there. This is not the case.

I have also set all columns to not editable. This did not help.

Is this a bug or does anyone have any suggestions that may help?

I’m guessing you are using a Card View.
The card views behave differently from the other Views for a collection of records.
We should be updating our documentation and make it clearer in the editor too.

If you want to remove this action from the card view, go to your Card View definition. Then click on the vertical ellipsis on the Card template in the editor. It will open a menu with 3 options. The first one is probably set to the action you want to remove.

1 Like

yeah, though, still a bug.

I can take a look

2 Likes

Clicking the vertical ellipsis on the Card template in the editor did then give me the option to delete the edit (or so I thought). Once I save the app, it just returns. Am I supposed to delete the form view shown below?

The system-generated views cannot be permanently deleted. If deleted, the system will recreate them.

1 Like

ok, that makes sense.
Is there a solution to the issue of the edit button that I do not want in the app?

Please post a screenshot of the card view configuration’s View Options section.

1 Like

Ok, here is the view I think you wanted

1 Like

I think I found what everyone was trying to point me towards.
I needed to click the dots and make sure none of the actions shown (action 1,2,3) were set to edit. Thanks all

1 Like

(1) Click on the three vertical dots; (2) select the action from the pop-up that changes On Click to Edit; (3) select None for On Click.

image

3 Likes

FWIW, I also have a fix rolling out on Monday that wll ensure that if the Action is marked “Do Not Display”, then it will not show in the app UI even if it was selected in the Card view configuration. This makes the Card view behavior consistent with the other views like Deck view.

4 Likes

Great! Changing the option to “Do not display” and still seeing the edit button was confusing.

2 Likes