Email attachment path not relative to google sheet

I have an appsheet app working from a google sheet.
In folders, located in the same folder as the google sheet, I have information about customers - the folder name is the customers name.
When I send an email with a pdf attachment, I would like appsheet to automatically save the attachment in the correct folder.
I have tried to accomplish this by putting [customer]&"/attachment" in the Attachment Folder Path, under my email workflow. Unfortunately, this creates a folder with path appsheet/data/Appname/(customer)/attachment and does not find the folder next to my google sheet.
How can i fix this?
Is there a way to put a folder ID, or some other way to ensure that the files end up in the correct folder.

Under Workflow’s definition, there is an option called “Attachment Folder Path”. Specify your folder name there and it should work fine.

Thats exactly what I tried, and it created the folder as a sub-folder of my appsheet/data/appname folder instead of a sub-folder of the folder where I keep my google sheet

The rules for attachment archiving are described in this article

1 Like

Hi Phil!
Unfortunately, I didn’t find the help I needed in that document either, the files are still saved in a path relative to the appsheet/data/appname folder in my google drive, and not relative to the folder where I keep my Google Sheet.

It sounds that I misunderstood your original post slightly. Are you able to change the spreadsheet’s location because you can’t set the location depending on the spreadsheet’s location.

Unfortunately, I need the current file structure, to enable some of the project managers access to the source file.

Are there any tricks with a folder ID, or similar I can use instead?

Not exactly sure, but worth checking.

Did you change the relative path on the Info pane, Properties tab as well? in addition to the relative path settings in workflow.

Here you push relative path to your folder googlesheet resides. My understanding is this is going to work as “Root” folder for workflow settings.

Then you add the relative path “counted” from this “root” folder.

My suspicion is you did not change the info/properties tab - Default App folder setting, so you app keep working this default folder as ROOT. Then you change the relative path on workflow, it still within the tree of this ROOT folder, so it will generate the new folders within root folder.



Yes that’s the way.

Will see.

That solved my problem, thank you very much :smiley:


Here you go!! Great to hear.