Email Template suddenly won't load

workflow
(Bill Joslyn) #1

I have an Email template that is attached to a workflow rule that worked just fine till yesterday when it would not load during a sync. No changes were made to the template or the table it is connected to.
Here is the error:

“Errors”: "Error: Workflow rule ‘Batch Summary’ action ‘Action 1’ Body template. Template could not be loaded due to exception: RemoveEnd mismatch: Expected: <<End>>, Actual ",

Any ideas on how I troubleshoot this?

(Levent Kulacoglu) #2

The Start expression in your template shall end with an <<End>> placeholder and that’s missing in your template.

(Bill Joslyn) #3

I kind of thought that is what it meant but every start has an end. Plus this template used to work just as it is. I just tried adding another <> just to see what would happen but that didn’t work. Would you be willing to look at my template?

(Philip Garrett) #4

Hi Bill,

I can investigate if you provide:

  1. Your account id
  2. The app name
  3. The workflow rule name
(Bill Joslyn) #5

Phil
account 233280
App Brew Log
Workflow rule Batch Summary

(Philip Garrett) #6

Investigating.

(Philip Garrett) #7

I have just deployed a fix for the problem.

I recently added the ability to include <> expressions in workflow templates.
When doing that I introduced a regression, which you encountered.
I am sorry about that. Thanks for reporting the problem.

1 Like