Enum Column is displayed as Text in Filter . How to have options?

Hello,

I have a virtual column in my ORDERS table named " Material " which actually is coming PRODUCT Table [Product].[Material] . This Material Column is actually an Enum Column but in filter (Advanced Filter), I am getting a text box expecting me to fill it where as when I filter in Product Table , it is properly showing the options with checkbox so I could check those boxes and submit .

Hi @Manish_Jain1 ,

How about setting the Data type of VC to Enum?
With the following settings, I was able to select the checkbox format even in the advanced filter.

3 Likes

Yeah I tried this but it gives me the warning

“Column Name ‘Material’ in Schema ‘Orders_Schema’ of Column Type ‘Enum’ should have a list of allowed values or allow the user to add other values.”

And I cant add values because I want it to come directly from the data .

Hi @Manish_Jain1,

If you see that warning, but you are able to Save, can you use the checkbox in the advanced filter to search?

Yes I am able to save and even see the checkbox. but just wondering if I should worry about this error…

1 Like

@Manish_Jain1

It’s a warning, so I’m ignoring it in this case.

1 Like

Thanks …I shall ignore too.

1 Like