ENUM Question - why button does state does not match current value

I have an ENUM column [Active], with values of TRUE and FALSE. I set Initial Value to TRUE. All works perfectly when I create a new record. The enum buttons show TRUE as selected.

But… since some of the records already existed in the gsheet, they already have TRUE as values in the Active column. When I try and edit those rows, the enum buttons do not reflect the value TRUE that is in the gsheet. Is there any way to correct this, or do I have to re-create all the records through appsheet? Just can’t seem to find a workaround…
image

UPDATE: Seems like if I edit each record through appsheet and sync one at time, the Active column now shows TRUE and is reflected by button status. I also noticed with the existing records that the gsheet has TRUE in the plain text cell, but Appsheet displays the value as True. When I edit the record, the value changes to TRUE both in the gsheet and in Appsheet.

gSheet:
image

Appsheet:
image

Wondering how I can avoid this and not have to edit each of the older records…

Sounds weird. Try copy and paste one of those correct values in your gSheet and see what happens.

@Aleksi - Thanks for the hint. The result seems a bit inconsistent. In the three tables where I use an [Active] column, I have the column set as ENUM with Base Type of text, and initial value of “TRUE”. I then set the gsheet column as Plain Text. Two of the the three tables seemed to show TRUE in the ENUM button now for all existing records. The third table does not … unless I go in and edit each and every row. Copying TRUE values from a working table did not seem not work. Strange. Still not so clear why this is happening…

It’s ok… I will manually update each record to fix. Just happy this is not a 1,000 record table!

Likely the preexisting values in the spreadsheet are not the textual value, “TRUE”, but the logical value TRUE. Try explicitly changing the spreadsheet column’s format to Plain text.

Thanks @Steve. Tried that. Even cut/pasted Cells with Plain Text type into the cells in question. Oddly did not work. No matter. I just changed all gSheet [Active] columns to Plain Text, and then edited each record in appsheet form. Now all works. Still odd :slight_smile:

1 Like

@Mike Any chance to see that situation any more? Do you have a copy? I would like to understand what could be the reason for this behavior.

1 Like

@Aleksi - I already manually updated all the records so unfortunately can’t show it …