Error across all users

Hi,

All of my users including me started getting this today.
I haven’t seen anyone else post about it.
What does it mean?

"Unable to add/edit/delete row in table ‘Fuel’. → Google.Apis.Requests.RequestError

The caller does not have permission [403]

Errors [

Message[The caller does not have permission] Location[ - ] Reason[forbidden] Domain[global]

]"

Why has everyone lost permission?

Is that table’s option called “Access mode” set with the “As app user”? You can find it from Data > Tables > table’s definition.

If you are referring to the access mode mentioned in security filters then no they are all set to “as app creator”. As they were before this issue arose.

Does the app creator (you?) have access to modify the Fuel spreadsheet/worksheet?

The owner is ‘me’ I can make changes to it and its on my drive.
Its odd because its not just this spreadsheet it seems to be every app on my account. I double checked that we had paid and we have.

Please goto My Account and Signout. Then Signing with your email address that is tied to your Appsheet app and see if that solves the issue.

1 Like

Just tried it, same result. I have a couple holding accounts and I tried all of them

Do you have any other sources than the main data source? You can find them from My Account > Data Sources.

1 Like

My Account > Data Sources is empty across all accounts by the looks of it.

I suppose I should add all of my sources?

I have one holding account that has this data source:
google-2

But I never added it.
No other account seems to have a data source and I tried adding them but it doesnt seem to show up.

Do we have any other ideas?
@Aleksi @Steve

Your problem is well outside my expertise, so @Aleksi is probably better suited. You might also reach out to support@appsheet.com directly to open a ticket on this.

1 Like

Have you checked this article about 403 error?

2 Likes

The Holding accounts permissions were set to view only.
:man_facepalming:

1 Like

Glad you were able to find out the reason :slight_smile: