Error Cloning App: A table with the name already exists in the database

Dear community,

I tried copying an existing App to a MySQL Database by following this documentation: Copying an Existing App to a SQL Database | AppSheet Help Center

But received this error message:

image

Creating a new App with the MySQL Database and cloning it to Google Sheet first works but if I try cloning it back to MySQL the same error message appears.

What am I doing wrong?

You’re not doing anything wrong. It’s just not possible to copy an app to an SQL datasource if any of the table names already exist in the SQL source.

It’s different when copying an app to a spreadsheet because the table names only have to be unique to that ‘container’ or workbook. But with SQL datasources, the table name has to be unique to the whole database instance.


I ran into this same problem when trying to establish shared tables between multiple apps using SQL datasources. I had support look into it but there was no possible fix. It’s just the nature of the datasource and namespace.

3 Likes

Thanks @GreenFlux!!!

Changing the table name in Data > Tables did the trick.

3 Likes