Error: Failed to save image

I’ve installed and App on 2 old-ish Android Tablets running 6.0.1. When I try to take a photo I get a “Failed to save image” error message when I click the tick after taking the photo. Presume its an uploading issue? Tried on 3 different internet connections, Appshet App has all permissions enabled and they both have a few GB’s of free space, there are no restrictions on editing this the image row. Any ideas?

I assume this was a NEW install of AppSheet on the old tablets? There were some changes recently in AppSheet on how they deal with the saving of images that required an update of the AppSheet container.

Also, I’ll assume you have tried taking photos with the device outside of AppSheet to rule out a device issue?

Hi @WillowMobileSystems. Yes its the first time these tablets have had Appsheet installed. Taking photos outside Appsheet seems to be ok, as does attaching existing photos

I am not an Android user but I wonder if the current AppSheet container requires a newer version of Android. I would ask at support@appsheet.com about your issue.

2 Likes

I’m having the same issue. If I use the “take photo” option, I get a Image Failed to save error, however, if I choose a photo from my gallery it attaches with no problem.

I’m using a Google Pixel 3 XL so I’m on the latest version of Android. My guess is that it’s a permissions issue, but I could be wrong. I would appreciate any insight.

Hi @Rob_Zehentner
have you tried clearing the cache on your app or uninstalling and reinstalling Appsheet app?

Perhaps your device doesn’t have room to store the image?

@ Lynn yes we tried that

1 Like

@Steve with our issue this wasn’t a problem

It is possible you may use your app on your mobile browser rather than appsheet native container app?

In the past I got the similar claim from my user who have been using app on their browser. On the browser mode, the photo being uploaded to app will be saved in so called browser storage which have size limit which cause failure to upload photo.

@tsuji_koichi no I was there, it was the App

Sure, then root cause somewhere else…