Error on adding tables to App

Getting the following similar errors on adding 2 different Google Sheets tables:

Table ‘Stock update’ must specify a schema.
Table ‘Stock Shipments’ must specify a schema.

Just in case any of this is significant:
= Both are sheets created by another google account but shared with edit access to this account
= Both are separate spreadsheet files as well as tables
= Both can be seen and opened by Google Drive and Appsheet ‘view source’
= Both are linked to a google form
= Both are working fine on another App in another Appsheet account

I’ve tried removing and adding but get the same error

We are simply trying to add these sheets to a publisher pro account so we can use an Appsheet form rather than the Google Forms

Any ideas?

I don’t know this for certain, but I read that only App Creators can add tables. I wonder if this extends to ownership of the sheets as well?

I would try placing a COPY of the sheets into your account, add those to your app so that the schema is loaded and then repoint the table source to the shared version.

Its just a guess!

1 Like

Hi @WillowMobileSystems

Just tried that and it works fine.

Tried to change the source path of the failing table and it was greyed out. Removed the link to the old sheet. Then went into the copied table and changed the source path, which was now available. Now getting no errors.

Convoluted, but it works! Thank You :slight_smile:

1 Like