Event not firing

Hello, Im having problems trying to make a automation works; I have an automation set up to copy a row to another table then deleting the rown from the first table but is not firing when de condition is met.
The condition is when the column debt(Deuda) is <= 0 the action should run, but is not happening.

The app reads the condition and marks it as true but it doesnt executes itself; I have to click on it to execute it.


I have also tried to use [_thisrow]/[Debt] but isnt working neither.

The debt calculation is made on the spreadsheet and I dont lnow if thats the cause, because another automatization haves a similar condition but it works properly.

We are going to need more details to help.

How is your event defined? Is it a “Data Change” event or a “Schedule” event?

Have you looked at the Monitor to see if any errors are reported and/or if the Steps of the Process appear to be running at all?

Are there any Behavior criteria specified on any of the actions that might prevent them from running?

1 Like

Hi, The bot PaidLoan is set up on data change:All changes but I have tried updates only and got no results, I have tried looking into the monitor tab but it doesnt detect any error it just doesnt fire the ation; and the only behaviors I have in the app are just that and other which copy the row value from table Loans to Pending Loans(the table I have set up the bot PaidLoan)

I would recommend reaching out to AppSheet support for more help. Email them at support@apsheet.com

1 Like