Experiencing unexpected error in Workflow - "... Please reset data to discard local changes." - How to fix?

In a Workflow in my app I am getting a weird error on a very simple Date Change action. I am certain that it was working as expected a couple months ago. I am retesting now after additional changes.

A couple weeks ago I did copy my app in order to change the appname which was bugging me. It was a sample app that has grown and wanted a more formal name associated with it. I had a couple of issues with views not working properly because the old appname still appeared in the Deep Link. But I updated the value to the new appname and they worked fine.

Based on the error message, I am wondering if there is something similar happening with this Action? I have tried deleting the Action and creating a new one as well as logging completely out of AppSheet. Neither helped.

Any ideas how I resolve this issue??


First 3 steps of the Workflow (Step 3 is where error happens):

The Audit Log

Error Details:

Properties:
{
“AppId”: “ea11df8a-9df1-4f29-afea-d6300774751b”,
“AppTemplateVersion”: “1.000247”,
“RuleName”: “Adjust Quantity on Hand”,
“EventType”: “Change”,
“InvokedBy”: “Add”,
“Server”: “produ991100007I”,
“IgnoreSecurityFilters”: false,
“TableName”: “WorkOrders”,
“RuleTableName”: “WorkOrders”,
“OperationUpdateMode”: “UPDATES_ONLY”,
“EventMatch”: “Workflow event successfully matched”,
“Condition”: “=AND([Work Type]=“Order”, [_THISROW_BEFORE].[Status] = “Working”, [_THISROW_AFTER].[Status]=“Done”)”,
“MatchesCondition”: “True”,
“ActionResults”: “Created 1 ActionResults”,
“Action Type”: “TakeAction”,
“Action Name”: “QOH Updated”,
“Errors”: “Error: This change cannot be applied because there is a newer version of your app ‘Service Insight Demo’. Please reset data to discard local changes.:”,
“AppTemplateName”: “ServiceInsightBase-526414”,
“Operation”: “Workflow action”,
“Result”: “Failure”
}

Hi John,

The error is being produced when we try to verify that the table schema for the update matches the current table schema. Having said that, I have no idea why your update is failing.

To find the problem, I will need to debug it. If you wish me to do that, please submit a bug report and provide the following:

  1. Your account id.
  2. The app name.
  3. The workflow rule name.
  4. The exact steps to reproduce the problem. (I will need to follow those steps and watch in the debugger to see what is provoking the error. When debugging I often need to repeat the repro steps several times to find the problem and then repeat the repro steps several more times to confirm that that fix works. Please provide repro steps that allow we to do them repeatedly. For example, if an Add is required, I may need to add several records. If an Update is required, I may need to do several update. Please tell me how I can do that.)
  5. Your permission to follow the repro steps and make the resulting changes to you application data.
  6. If you prefer, you can make a copy of the application and I can debug with that. That reduces risk but it is more work for you. If you do that, please ensure that the problem is still occurring on the copy.

@Phil I opened a Bug report here.

Please let me know if you need additional information.

Hi John,

I hate to ask you to repeat work, but can you enter your bug here https://www.appsheet.com/Support/Contact

Bugs you enter that way go into the bug tracking system so don’t get lost.
Bugs entered in the community rely on my memory (which is terrible) and can easily get lost.
I am really buried at the moment and there is a real risk I will loose track of your bug if it is not in the tracking system.

Thanks in advance.

1 Like

@Phil At the moment, I do not have an actively deployed app. I am working towards my first. So, the link you supplied does not allow me to submit a support request. Other options?

Hi John,

Sorry about that, but thanks for trying.

I will try to keep track of it, but if you don’t hear from me please remind me.

Ok, will do. It might be nice to know when you are debugging it so I can stay out of your way.

I am trying different things to resolve. For example, I just tried executing the Action from a button and it succeeded as expected. The same Action fails when executed from the Workflow.

I may try next deleting the Workflow and re-adding it.

@Phil I’m sure you are still busy with other more critical things. I just wanted to provide an update of what I have tried and noticed.

Observations:

  • I’m fairly certain this was working as expected a couple months ago.
  • Problem occurs with Workflow steps that go directly to Data Change action on WorkOrders table.
  • Similar Actions from Workflows against different tables, DO NOT seem to encounter the error.
  • If I activate the Action with a button, it works as expected.
  • If I wrap the action in another action - Execute action on a set of rows - and simply pass [_THISROW], it works as expected.
  • If I create another similar Action from a different Workflow on a different column in SAME table, I still get an error.

I have tried:

Deleting the offending action and re-adding with different name.
Deleting the column and re-adding with different name.
Deleting Workflow and re-adding with different name.

Potential next steps will be more intrusive. I’d rather you perform your debugging magic to isolate the real problem before trying anything else. It may be a bug that contributes to other issues and worth investigating.

I am investigating now.

1 Like