Expression In action Works In Test Only

Hello

I have created an action to set some columns…
When i test my expression i can see it works, however, when i run my action nothing happens. I’m using a slice that has the same issue, when i test my slice i see results, but when i view it there is nothing there.

My result for the action

Hi @1111
There does not appear to be anything in the [GuardPatrolID] column. Also is it [GuardPatrolID]
or [GuardPatrol ID] with a space?

1 Like

The expression result value should be in the Guard Patrol ID column

Ok , have you tried ANY(SELECT…?

1 Like

I am curious, is it normal to have different wording between what is shown on the top of the expression tester with the table name? I saw a “space”.

1 Like

Please post a screenshot of the action configuration.

Please also post a screenshot of the slice’s row filter expression.

1 Like

There are a few instances where the expression builders preview results will be different than what the actual app shows.

This is due to the fact that the expression builder is something that’s running on the AppSheet editor - while the formula for your app is being run by your app. They have different parsing mechanisms - there was a detailed post about this years ago by Phil I think.


Generally it’s just a matter of reformulating your formulas - thankfully, in AppSheet there is…


If this is the formula you’re working with - the issue most likely is due to the fact that in your tables you’ve got two columns that have the same name:

  • [SITEEMAIL]

I would suggest changing the names of these columns so the uniquely identify each from another:

  • Daily_Guard_Patrol_Site_Email
  • Other_Table_Site_Email

Generally speaking, it’s best to have all the columns in your app have unique names.

Try changing the names and see if that works, your formula is pretty straight-forward, so it doesn’t look like it’s a matter of a complicated formula. I recently went round and round for hours trying to solve a workflow issue - problem was due to identical column names.

2 Likes

My slice’s expression was:
AND([DATE]=TODAY(),[FINISH PATROL]=TRUE)

I ended up using something else as i realized that [FINISH PATROL]=TRUE was not really calculating

AND([DATE]=TODAY(),ISBLANK([FINISH PATROL])=FALSE)

However, i also found that if i use a number instead of a true/false it works:

AND([DATE]=TODAY(),[FINISH PATROL]=1)

4 Likes

Data types - they make all the difference.
:nerd_face:

Usually i get a warning about wrong data types, in this case there were no signs :grinning: