Expression updates a cell with all records in its specified column separated with commas

Hi, all. this expression :
TRANSFER DETAILS[CUSTODIAN]
fills the cell that i want but concatenates the values of all the records separated by commas, instead of one.
i didn’t expect it to be a LIST, but a single value from the current record being added to another table.
i’m using it in an Action to update with “set the values of some columns in this row”
i’ve tried various other expressions with Select and Lookup and the cell remains empty.

can someone help, please?

@Eso_Surveyors
Have you tried with [_THISROW].[CUSTODIAN] only?

thanks, @LeventK.
the table source of the data is different to the table target, namely source table is TRANSFER DETAILS and i want to update table ASSETS.

@Eso_Surveyors
Yes I do understood that. That’s why I proposed use of [_THISROW]

this expression in the Assistant: [_THISROW].[L = Labelled E = Engraved]
gives me this error: Error in expression ‘[ESO No].[L = Labelled E = Engraved]’ : Unable to find column ‘L = Labelled E = Engraved’
so it’s not looking at the TRANSFER DETAILS columns, rather looks at ASSETS columns.

Are you trying to update a column’s value in an other table from the table that you currently viewing?

yes, in brief,
the Action must update table ASSETS,
with a value from table TRANSFER DETAILS
action is triggered by a record ADD to table TRANSFER DETAILS

@LeventK do you want to look at the APP?

@LeventK, action already fills the correct cell i want but puts all the valued of that column from all records in TRANSFER DETAILS separated by commas, including the values i want, i.e., the very last after the last comma.