Extra whitespace in template, table with image

I’m having an issue with extra whitespace showing up in a GDoc pdf template. Here is the basic format of a single page:

I’ve given the top table a minimum row height as indicated by this GDoc setting:
image
This prevents smaller images from shrinking the output much under one page, since it is a START expression that should output multiple pages, one per START iteration.

I’m also attempting to use the “Workflow Template Format” Format rule for “medium” images (600x600), which should fit very well into my template, but I’m getting a large amount of whitespace after the image, which pushes the second table to a second page.

Here is the output of the first table, where you can see the additional whitespace. The height of this table is closer to 8 inches, the minimum setting should not be affecting it.

To be sure the minimum settings was not affecting it, I set it to zero and tried again with no change. After setting to zero, here is what it looks like in the template itself:
image
As you can see, there are no extra line breaks or anything obvious to explain the extra space.

How can I get rid of this space?

1 Like

Hi @Marc_Dillon have you been able to solve this? I saw this happening to my Templates as well.

I’m afraid I cannot remember what eventual happened with this, sorry. If you post your issue in more detail I’ll try to help though.

I have 2 issues. One is the one you explained: Sometimes I have a big white space after an image.

The other I posted here:

I’m not sure if this has been resolved, but in my experience you need to DELETE the Workflow Template Image Format as the Appsheet default sizes overrule the GDoc formatting.
Disabling the Format Rule for the image size has no effect, you need to completely delete it.
Maybe I needed to clear my cache after disabling but DELETING the format rule worked for me.

1 Like