"filter out all existing rows" table takes seconds to sync

Many of my tables that have “filter out all existing rows” enabled started to appear as 1,5-3 seconds to sync , in performance analyzer. I never noticed them in the past. In general they are the smallest and simplest tables for collecting data only. Bigger non read only tables, with hundreds of rows or 15k cells ussualy takes less to sync in the same performance analyzer.

For testing, I disabled the “filter out all rows” option , and set the security filter to a simple “false” . That sync time dissapeared.

I only use google sheets tables.

  1. Did I missed the “filtered out all rows” tables before in performance analyzers? Or could this be a bug ?

  2. What is the actual difference between “filter out all rows” and a “false” security filter ?

As a side note, a lot of different sync times seems strange recently. For example, I have a read only table with 34 cells , that in 80% of the time it shows as more then 2 seconds to sync (again, no sheet or app formulas,no VCs,nothing that makes sense, with delta and server caching enabled) , while another non read only table with thousands of cells syncs faster in the same app . Months ago, I believed that sync times will drastically improve , thinking that transfering data from google servers to appsheet servers to user device will somehow become a shorter route google straight to user, but these days is fells a bit of a slower sync then before.

Thank you

An example from today’s testing