Filters in Dashboard disappearing

I’ve got an app with two basically identical dashboards.

The first one is a list of students with these views:

  1. grade level filters - ref / detail view
  2. filtered list of students - ref / deck view, uses a filtered students slice based on the filter selected
  3. student details - system generated detail view for the filtered students slice

Everything works perfectly in the student dashboard.

I also have a courses dashboard which is set up the exact same as the student dashboard. All three views are the same and the filters are set up exaclty the same (filtering by grade). Everything in the courses dashboard also works properly except for one minor glitch.

Once I click on a filter the courses list is filtered properly but then when I click on any course (filtered courses deck view), the filter buttons disappear. Once I deselect the course, the filters return. Does not happen with the students.

I’ve gone through the settings of each slice, dashboard and component views for both and everything is identical.

In the first screenshot there is no course selected, filters are there. In the second, you can see I’ve selected a course and the filters disappear. I’ve tested and they even disappear if there is no filter selected and I click on a course.

Thanks in advance for any help!

Edit: I added my filtered courses list and its detail view on the student dashboard. I then connected the filtered course list to the same filter controlling the filtered students list. Students still behave as before, the filters work and selecting a student doesn’t make the fiters disappear. However, in the same dashboard, the filters correctly filter the courses list but when I select a course the filters disappear.

Thanks @Steve, but I’ve already got Interactive mode turned on for both dashboards. I’ve added all views to the same dashboard so you can see the the difference side by side.

In the first screenshot I’ve got one student selected and no courses selected. You can see the filter buttons are still there. In the second screenshot, I’ve selected one of the courses and you can see that the filter buttons disappear. When I deselect a course they reappear. The same behavior exists if I move the courses list and course info views to their own dashboard.

Selecting or deselecting a student doesn’t change the visibility of the buttons. It’s only when I select/deselect a course that the buttons disappear/reappear.

No course selected - filter buttons visible.

Course selected - filter buttons not visible.

The filtered students slice has the following row condition:

IF( ISNOTBLANK( SELECT ( Staff[Student Filter] , USEREMAIL() = [Email] ) ),
AND(
[Status] = "enrolled",
[Grade] = RIGHT( ANY( SELECT ( Staff[Student Filter] , USEREMAIL() = [Email] ) ), 1)
),
[Status] = "enrolled"
)

The filtered courses slice has the following row condition:

IF( ISNOTBLANK( SELECT ( Staff[Student Filter] , USEREMAIL() = [Email] ) ),
AND(
[Year] = 2021 , 
[Grade Level] = RIGHT( ANY( SELECT ( Staff[Student Filter] , USEREMAIL() = [Email] ) ), 1)
),
[Year] = 2021
)

The filters are working as expected. If I select M3 then it only shows the students in the M3 grade level and the courses for the M3 grade level. FYI, the M stands for Matayom which is secondary in Thailand. M1 = 7th grade, M6 = 12th grade. The RIGHT expression in the slice row condition is pulling just the number from M1, M2, etc…

I’ve also tried this with separate filters for students and courses and I get the exact same behavior.

1 Like

I struggled with the exact same issue a few days earlier, but thanks to a quick tip from @Marc_Dillon I was able to resolve it (not exactly troubleshoot it).

I guess the filters are set up in the same table as the main users table.

I would suggest setting up a different table for filters, which would contain a column as reference to the user table, and additional columns set up as filters, all that there can be.

Now implement the expressions so as to work with this table. Your issue will be resolved.

I’m not sure what causes this behavior, but since it worked for me, I would leave the grain of salt.

3 Likes

@Pratyay_Rakshit That worked!

When I had the filters in my Staff table, the filters didn’t disappear on my Students dashboard but they did disappear on my Courses dashboard. The Staff table has a reference to the Courses table but not to the Students table. I wonder if it’s the ref that’s causing the problem. I’ll have to investigate with a dummy app later but don’t want to start playing around with refs in these tables right now.

Thanks for the help!

2 Likes