Folder path for .pdf Files in file field

I am trying to get the folder path to work for my PDF’s.
I have made it work using the full path and filename in the spreadsheet.
I have made it work by having the filename in the spreadsheet and then the pdf sitting in the same folder level as the data spreadsheet location.
I can’t get it to work with the folder pathing in the file type field definition.

The path that works in the spreadsheet is:
01 Drawings/Permanent/Civil-Electrical - CIEL01/Single Lines/28010A1-DES-000CIEL01-DRG-0213.pdf

I have tried this in the field definition:
“01 Drawings/Permanent/Civil-Electrical - CIEL01/Single Lines/”&[Single Line drawing Number]&".pdf"

[Single line drawing number] is the field that contains the drawing number.

It does work with the full path but it is very messy on a form and doesn’t allow changing the drawing number easily.

URL to the files are made within Virtual column to dynamically set the url?
Why dont you encode the part of relative url, and see what happens.

“01 Drawings/Permanent/Civil-Electrical - CIEL01/Single Lines/”&encodeurl([Single Line drawing Number])&".pdf"

Or alternatively why don t you use the full path, but change the text appearing to user by using hyperlink() expression?

I haven’t used a virtual column I have used a file field type.

I have set the folder path to the file to this:
“01 Drawings/Permanent/Civil-Electrical - CIEL01/Single Lines/”
The field value is DrawingName.pdf

The data spreadsheet for the app is located in:

\CR2SM Electrical\

The folder with the file is located in:
\CR2SM Electrical\01 Drawings\Permanent\Civil-Electrical - CIEL01\Single Lines\

Are you dynamically changing the folder path based on Drawing number?

The folder path stays the same, it’s just the drawing number that changes row to row.

It looks like the issue might be in the system generated action as it only points to the field value and doesn’t add the folder path to the action.

Yep I created my own action, put the whole path in the File section of the action. Set the system action to do not display and set the action to display inline.

This does work fine for me but it would better if it worked from the file field type folder path in the column settings.

I suspect still your file path is doing something wrong to display the file on browser by linked URL.
I usually save the file into default folder, i.e. “Attachments/” then I generate the full path to access to it with virtual column which is easy set and especially more stable.
But I sometime faces the issue, the url not returning the actual file I wish to access. The majority and sole reason for the problem was the ULR has 1) Space, 2) special characters.

So to eliminate the issue, i use encodeurl() expression when I use the expression to construct the dynamic url out of relative file path.

Your file path is eventually used within the full path to access to the file?

Currently you define path like this

“01 Drawings/Permanent/Civil-Electrical - CIEL01/Single Lines/”

It contains 1) Space 2) special character like - .

This need to be encoded, so that the url is returned correctly.

I have got this working well enough but now when the PDF opens on an iPhone I have no back button to return to the record.
the only way out is to crash the app and re-open.

@morgan
@Aleksi

This is happening to my app as well. Morgan could you please investigate? I open PDF fie saved google drive using full path constructed by VC and it opens but no return button on the top. I m using I phone 11 FYG
The back button now disappears.

I am using an iPhone 11 Pro max with IOS 13.
I have found that if i swing the phone to landscape and then back I can see the back button.

Thanks for the “tips”.

Not only PDF, but when I open up the browse with url link from Appsheet, the external service is open, but no return button. As you said, I show it on landscape and bring it back to portrait, then the return button available. Strange.

@Aleksi
@morgan