Form bug? entries not editable not appear on the form

ux
(Dexpertio LTDA) #1

I want to create a form view. But it seems that the entries that I leave as not editable and with app formulas or initiatial value do not appear on the form. And since one of these entries is the key to the row, the form is not saved

(Levent Kulacoglu) #2

@Dexpertio_LTDA
Are you using Editable_if = FALSE with those fields? To the best of my knowledge, you cannot use Editable_if with the Key Column value. Can you please elaborate your query a bit more?

(Dexpertio LTDA) #3

Yes, I am using Editable_if = false. But I want That Column be not editable. How I can do To have a form that have the key column not editable?

(Levent Kulacoglu) #4

@Dexpertio_LTDA
Provided you do not need to show the key column value to the user, you can use Show_if = FALSE

(Steve Coile) #5

You can set Editable_If to FALSE for a key column. I do it routinely. However, the column must have an Initial value expression that produces a non-blank result.

(Dexpertio LTDA) #6

I tried the ways you have recommend. It doenst work

(Aleksi Alkio) #7

Do you have anything in the “Initial value” field?

(Dexpertio LTDA) #8

I think I’ve realized what’s happening: going to the form comes directly from a users session. But it does not look like there can be a direct route to a form. And there occurs this bug.

(Levent Kulacoglu) #9

@Dexpertio_LTDA
You can use LINKTOFORM deep app link to create a direct interaction with the Form UX

(Dexpertio LTDA) #10

But it seems that not by user seting

(Dexpertio LTDA) #11

I tried to create a LINKTOFORM, but it does not appear to direct direct from the Usersetings