Form - Child selection manadatory not working

I have created a form in which I am creating Row Flag entries. Row table is Parent and Row_Flag table is Child table

image

I need to make child selection mandatory. Users must need to select a reason for Flagging the row. In column structure Required is disabled by default.

I tried ISNOTBLANK([_THIS]) in the virtual column but it is not working.

Any suggestions would be great. :slight_smile:

Look into this workaround: How to make child form "required"

1 Like

Thanks @Bahbus. Thanks for the link. Yes, I referred that article and I implemented that solution but it doesn’t look good.

Whenever a form opens, an error message comes automatically.

image

How did you implement it? Can you post a screenshot of how its implemented and the related columns? It’ll be easier to make any future suggestions.

@Bahbus :


I added expression in one of the column in form Row(s). In virtual column, I did nothing.

Ok, so here is what I would do. Create a brand new virtual column in your source data called Flag Count that uses numbers. Give it an App Formula of COUNT([Related Row_Flags]) and a Valid If [_THIS]>0. Then, set the new VC column to not be shown. Make the description for [Related Row_Flags] something like “Must select at least one Flag:” or whatever would make sense for your users. The form will now no longer let them save without selecting a flag. There won’t be any error messages visible, but it should solve the biggest problem.

@Bahbus : It’s not a good idea. Currently, Virtual column’s Valid If is not preventing the user to save the form. We must need to rely on normal column’s Valid if.

You can’t make a valid if that works directly on the VC for the child table. On a new one that is seperate from it, it should work. I have tested this before. It is completely different than trying to put a Valid If on a reverse reference VC.

@Bahbus : Yesterday, after reading your reply, I created one VC and copied the expression from normal column’s Valid If to VC’s Valid If but it was not working. Maybe I did something wrong.

Can I see the new one you created or did you change it back already?

@Bahbus : I changed it to previous one. I’ll do it again and will post you if it still not works. Thanks :slight_smile: