Format Rule not showing

COUNT(SELECT(view1[Site],[Site]=[_THISROW].[Site]))=1
When I test the above formula in my expression assistant it returns true for a handful of rows but the format is not applied to any rows. When I just set this as true they are formatted so I know i have the right columns selected.

Format rules are applied to columns or action buttons. Did you choose any columns and/or actions? Are any of the chosen columns or actions present in the view?


Yes I have every column selected.


I’ve even changed the Count formula to be a virtual column and still nothing

I would have to guess the view displayed is not based on the view1 table.

image
View1 is the only table in the app and there is only 1 view in the app

I’m afraid I’m at a loss, then. Off to support@appsheet.com with you! :wink:

They know me well lol
Could it be since I’m using a virtual column it’s not calculated before the format rule is checked?

The VC value is updated under the following conditions:

  • The row is updated by a form save.
  • The row is updated by an action.
  • A sync occurs.

So you’d need one of those to occur to see a change in the VC value. The format rule itself should take effect immediately upon the change, if I recall correctly.

The Highlight Color setting is for the color of the icon. From what I’m seeing you should see a Green Anchor in front of every column.

Since you’re not, try setting the Text color to see if at least the column values are getting formatted.

Here are a few other things to check:

  1. Make sure there are no other Format Rules that are overriding this one. If multiple rules apply, the last one wins!

  2. Make sure you have saved the changes!!

  3. Launch a Browser version to see if the Format Rule is being applied there.

  4. Close and relaunch the editor.

I have seen some unusual behavior recently, delays in info showing. I gave a demo on Friday and was embarrassed when a couple new rows didn’t show up where they were supposed to - in a demo app that has been running great for a year. On Monday, I opened the app to investigate and there were the two rows right where they needed to be. Ugh!

2 Likes


Text color was already being applied as well, it’s the only format rule in the app, tried on my phone, on editor in phone and tablet, and tried full screen, I have refreshed the app, refreshed the tab, and restarted chrome.

Now it’s applying the format rule randomly to rows regardless of the formula so I’ve resorted to support@appsheet.com

2 Likes

Any answer to this? I’m using a similar formula [column]=“desired value” but the formatting is appearing randomly. Like desired value 1 is appearing on desired value 2.

Ignore. Found my issue. I had the wrong column selected as the Key. This caused the confusion.

2 Likes