Formatting of Workflow, Report, and PDF attachment (Gap at top of email)

Hi! I have had issues formatting my workflows until recently. The problem was that there was a huge gap in between the top of my workflow and the top of the email. For anyone who has this problem and wants to fix it, here are 2 simple steps to fix the issue…

  1. Make all page margins equal to 0
  2. Make document “A4” in Page Setup

Hope this helps someone!

1 Like

Thanks for posting this Nick.
I have added it to this article https://help.appsheet.com/en/articles/961739-troubleshooting-workflow-emails

2 Likes

There is a help article on formatting your templates.

Template Formatting Tips

The following tips may help you control the appearance of your PDF attachments.

  1. Under Format > Line spacing, reduce the line spacing to Single if it is currently larger, such as 1.5 , Double , etc.
  2. Under Format > Line spacing, remove Add space before paragraph and Add space after paragraph .
  3. Under Format > Paragraph styles , change the header formatting to Normal Text rather than Heading 1 , Heading 2 , etc. Then apply formatting to control the header’s font size, color, boldness, etc.
  4. Remove any excess blank lines.
  5. Under File > Page setup… , check the page size and margins. For example, consider setting the page size to A4 and reducing the top and bottom margins.
3 Likes