Generated PDF File and Folder not saved - yet Email task can properly attach

Wasn’t sure if this should go here or Automation category, so I’ll start here.


I created a Reporting Bot process with two steps -

  1. Create and save the PDF file
  2. Send email with retrieved PDF file.

In a private version of an app this all works as expected, file is created and saved in a folder named “Reports”, email is sent with generated file attached and File button in table view loads the PDF document for viewing.

I migrated this process to an app I am a co-author on. An email is sent with the correct file attached but NO FOLDER IS CREATED AND NO FILE SAVED. This is odd since the Email step is designed to retrieve the File after is has been saved in a prior step. The File button in the table, of course, does not display the PDF since no file is saved.

There are no errors reported, and logs indicate the correct path, etc. I have checked and double checked the private version process against the one in the co-authored app. I have had the App Creator/Owner check the cloud to see if maybe the folder was created somewhere where I do not have permissions. No folder found.

Questions are:

  1. When generating a file to save and specifying a Folder in the task, what is the expected root location to create that specified folder?
  2. Assuming the process between the two apps is identical, what could cause the private app to save properly but the co-authored app not?
  3. How can the Email step pick up the file to attach to an email that was supposedly saved to a file and folder in a prior step yet no such file or folder exists?

@Steve - Thank you Steve!

1 Like

As one additional test, I copied the co-authored app back into a private app, changed ONLY the email address the email is being sent to and re-tested. Everything is working as expected!!

Something is preventing the Reports folder from being created and the file saved to it. Yet somehow the Email step is able to pick up that file to attach to the email!!

Sounds like another new bug unfortunately… :sleepy:

1 Like

I have run several tests and I am escalating this to a bug.

To recap:

When I run bot in the co-authored version of the app, the generated PDF is not saved nor is it’s folder created and no errors are produced anywhere - yet the Email task can pick up the file and email it.

When copying the app to my personal account, all functions work as expected - folder is created, file is saved, email is sent and clicking the file button in the app properly displays the generated file.

2 Likes

Thanks for sharing a bug before we lose our time and lose a way. Hope it will be fixed soon.

One additional update: I have had the App Creator try the same process to generate the PDF. The same result was experienced. So it is not related to the fact that I am a co-author and potentially facing permission problems. It appears the issues is app-wide.

Now the question is why this app and not in the copy I created? AppSheet is looking into it.

3 Likes