Generated PDF shows table border lines on Android and PC - remove?

I have create a set of Quote and Invoice templates that generate PDF’s and attach to emails.

Since Bulleting does not carry over into the generated doc, I have simulated using tables in the template. To prevent the table borders from showing, I set the border widths to zero.

However, my client is indicating the borders are still showing on his devices - PC and Android phone. On my Apple devices the borders do not show iMac, iPhone and iPad.

I have also set the border color to white and waiting to hear of that works.

However, I thought I’d check with others here to see what they do for this issue. Comments?

1 Like

Hello @WillowMobileSystems, i’ve ran into the same issue.

Now i set the border widths to zero so that it doesn’t mess with the column spacings (i work mostly on excel-like google doc templates) and set all the undesired borders to white, and i’ve had no issues since then, so i believe you have already solved your problem.

2 Likes

Yes, setting the border color to match the background color is the way to hide the borders.

It is interesting that the zero-width borders show in different cases for you though. I would have assumed that a PDF is a static image that displays exactly the same on all devices.

2 Likes

Agreed. One thought I had is that maybe the viewers are treating the table borders similar to Excel Gridlines. In Excel, borders and gridlines are separate display items. Gridlines can be turned on or off but have no width nor color variability.

1 Like