Getting the following error when trying to lo...

references
(Jonathon Sinclair) #1

Getting the following error when trying to load apps outside of the editor:

Unable to fetch app definition.

Error: Data table ‘staff’ is not accessible due to: Object reference not set to an instance of an object…

Thoughts?

#2

Hi @Jonathon_Sinclair, could you email support@appsheet.com with details such as your account ID and the names of the apps affected?

(Jonathon Sinclair) #3

@Adam_Stone_AppSheet Done!

(Jerry Renfroe) #4

I’m getting same error

(Jerry Renfroe) #5

But, it only occurs when viewing in web browser

#6

We’ve just rolled back the update that went out earlier today until we can find the source of this issue. So if you refresh / relaunch the app it should hopefully be back to normal.

(Spencer Jones) #7

Same error. My Audit Log is showing that all my users are trying to do duplicate requests.

#8

The duplicate requests shouldn’t be anything to worry about. The app will keep retrying its updates, and after about 10 minutes the original request will time out and the updates should start processing again.

(Spencer Jones) #9

The Duplicate Request error is still being problematic on multiple of my apps. Everyone stopped working for 10 minutes and it still won’t process requests.

#10

@Spencer_Jones Were these happening before today? Do you see any successful syncs happening in the audit logs, and if so, how long did they take? Duplicate requests can also happen if sync time is long enough that the app connection with the server times out before the sync has finished.

Can you email support@appsheet.com with your account ID and the name of the app?