Google Calendar: Get rid of Hangouts & Meet

When you use Google Calendar as a data source and add an entry via your AppSheet App, a Google Hangouts / Meet Link will be added automatically.
This may be useful. If not you can disable it.

Free Google Account

  1. Open your Google Calendar Settings
  2. Scroll down to “Event settings” and disable "Automatically add Google Meet video conferences to events I create"

G-Suite / Google Workspace

  1. Sign in to your Google Admin console.
  2. From the Admin console Home page, go to Apps > G Suite > Calendar .
  3. Go to Sharing Settings > Video conferencing and click Edit.
  4. Uncheck the Automatically add video calls to events users create box.
  5. Click Save .
6 Likes

I have to admit that this is not working.

Here is what @Joshua_Aldrich from the Support Team wrote:

So yes we do automatically add a conference id to every google calendar event. I perused the code and this is done while updating the gcal row. Currently the way we are exposing the gcal data source it does not provide a suitable mechanism to choose not to add the conference link. Also, because it is explicitly adding the conference link when creating the row entry in gcal it is not going to observe any settings in your gCalendar account. We cannot currently remove this auto link though because folks who would expect a meeting link would no longer see them. This seems like a good candidate for a feature for the front end team to add as an option and then we can switch behaviors based on that.

So I tried another way: I turned off Google Meet in the Google Admin Console.
But this leads to another bug: If you add a calendar entry via the AppSheet App, everything looks nice, but it will not add this entry in the Google Calendar. I think because AppSheet wants to add the Google Meet Link, but my Admin Settings don’t allow this.

To me this is a bug that should be fixed.

1 Like

I believe we have finally fixed this issue. @Fabian please try and let us know.

We now check the calendar setting and add a Meet link based on that.

While we were modifying the calendar code, we also made sure that a new table based on a Calendar sets up the Start and End time to ignore seconds and sets up the end time to be a 30 min offset from the start time (Initial Value expression).

Small changes but things folks have complained about

1 Like

Hi @praveen thank you so much for those improvements.

This is working perfect now. Now the Tip in my first post is working :slight_smile:

This is very cool, but I think it should be the same as under the Calendar Settings > Event Settings > Default Duration.
image

1 Like