Google Sheets data old when I view it (missing new items) - but AppSheet can see the latest?

I have a simple app I’m trying to make, and I could add things fine on the mobile app, but suddenly this morning the “sync” seems to have frozen. At the top of the app it says “Syncing the app… and then Last Updated xxm ago” with the minutes just slowly counting up.

I’ve searched the help stuff, but the article seems to say that pressing the sync button (in my case, its just the default refresh button at the top right of the mobile app) should fix this. Is that right?

I have no connectivity issues - full wifi strength. All fine. But now there are lots of things I’ve added to the mobile app that aren’t in the Google Sheets its based on.

I was hoping there would be a simple article on “sync problems? here’s how to problem solve” or something :slight_smile:

BTW this is the (unhelpful) article I kept getting to: https://help.appsheet.com/en/articles/953859-sync-between-the-app-and-the-backend#:~:text=For%20apps%20that%20work%20primarily%20offline%2C%20the%20app%20creator%20should,is%20started%20by%20the%20user.

And this is what I get when I try to search this forum for answers (see attached images) - literally nothing found! So odd.
search forum - nothing1
search forum - nothing2

https://community.appsheet.com/search?q=sync
https://help.appsheet.com/en/?q=sync

Thanks Steve! That way I tried of searching must just be broken?

Update #1: I’ve tried changing the settings for the app, in BEHAVIOR>OFFLINE SYNC. Have enabled SYNC ON START, and turned off DELAYED SYNC, to try to make my device sync. Nope. I exited the app and came back in - and still, all the items I’ve added this morning (via the mobile app) are sitting on the device but not in my database. (WRONG - see update #2, they ARE in the database)

Update #2: This seems to be a Google Sheets issue. Has anyone had this before? For some reason, it is showing me an OLD version of the database when I try to view it in Google Sheets (!) - both on my mobile device and desktop and iPad. But AppSheet itself is “seeing” the CORRECT latest version - I know, because on my desktop it is “Seeing” all the things I added this morning to the Google Sheet via my iphone! So strange! :-)))))))) I hope anyone finding this thread later with Google will at least get some help. I shall try to figure out what is going on!

Anyone know what is going on?

Probably best to engage support@appsheet.com for this one. :frowning:

1 Like

For any google search folks - the solution was to go to Data > Tables> view source to find out where the app was actually getting its data from. Turns out that I moved the original Google Sheet into a folder, and AppSheet “broke off” its link to it, so it created a new one at “/GoogleDrive/appsheet/(nameofapp)/” with the name of my first worksheet inside the Sheet. It didn’t tell me it had done this lol but there you go! :slight_smile:

1 Like