Google template column width

Hi all!
I’m having a hard time with the column widths on a table in my PDF report, seems no matter where I set the template column width, it gets some sort of auto width based on the content.

I read something about using <> before and after table but confused on exactly where to place them. My tests just treated them like text.

Thanks for your help!

You using Google Docs?

Yes Sir! Open to other ideas if need be.

Do you want to share your template with and I’ll take a look? I’ll need edit permissions

Done, thanks Simon!

Can you also email me a couple of PDF examples of where its resizing?

I’ve experienced the same problem. Tried resizing fonts, etc and problem still exists.

@Joe_Benson1 by all means send me yours too

Thanks Simon but it probably won’t help. The original doc looks fine. It only happens when data fields are populated by the app and it’s converted to a pdf for e-mailing or saving. The vertical lines of the table seem to realign on each row depending on the data in the cell. There is no sign of this happening on the original document. Reducing font size makes little if any difference. You can try this for yourself. Make a simple table in a Google Doc and fill it with variables from an app data source. Create an action/workflow to attach the resultant pdf to an email and look at the result. You will see what I mean.

I’m curious, was this ever resolved? I am seeing the same issue with column width and wondering if there is something I can do to correct it - make the columns widths statics from row to row.

I recommend paying attention to these options in the Table Properties (right click the table in the doc)


Creating nice-looking pdfs is always a time-consuming struggle for me, but I’ve plowed through many times. Let me know if you need more help.

Yes, I am massaging those settings. At one point I unchecked the column width setting so the table filled the page width. Then I “reset” the column dividers.

Where it is really strange is when I create a single row table used for repeating rows such as with a SELECT() or REF_ROWS() list inside of the template. The columns in the output are of different widths from one row to the next even thought the data is of comparable widths.

Is there something I need to do to force constant columns widths in the table?

Here is my template table:

And this is the resulting output

Try putting the start expression in the first cell of the row, instead of before the row, and the END in the last cell.

1 Like

I will try it to see if that makes a difference in column width.

Yes that worked!! I was skeptical it would. Interesting!

I liked the placement of the Start/End outside the table because it is somewhat easier to read. It worked that way for me before because I was using multi-line tables. So I didn’t have an issue (or at least see one) with mis-aligned columns.

Thank you!!

1 Like

Great! It appears that your start-expression table is separate from your header table, yah? In that case, what the Start expression is doing (I think), is creating a whole new HTML table with each iteration, which means that each row is separate, and so nothing is binding the columns widths together to be the same. Moving it inside the table makes it so each iteration just makes a new row in the table.


Thank you