GPS not working in workflow

I use a form, “TrlComments”. In that form, I have a field called gps. I have tried using both Changelocation as well as lat/long. Neither work. I get an error on my iphone saying “Unable to get current location. Please enable Location service on your device and then restart the app”.

Update… it is working on my computer but not on the phone. GPS is enabled, device has been powered off and on. GPS is working with all other apps.

Update, Update…
So, I made a condition to only allow the field “location, or GPS”, (depending on which field I was using). anyway, I made a field that will only allow it to show up if “Report to safety = True” with a yes no, button. When I select lat/long, the field will show up when yes is selected. However, I still get the error on my phone with the above error message. However, if I switch it to “Changelocation”, the field will not show up or record my location. It won’t work on either my desktop or my iphone.

Sounds like your phone is configured specifically to not allow AppSheet to get the phone’s location. You’ll probably need to adjust your phone’s settings. I don’t have an iPhone so I can’t offer any specific guidance.

2 Likes

Hello @dan_R

I was just going to suggest that you reset the cache/storage for the AppSheet app - starting over essentially.

This might clear up any erroneous settings that might be conflicting.

1 Like

I think that it is related to your phone settings vs Appsheet. If testing the application on the phone did not prompt you to allow ‘Location Services’ then I would suggest going into phone settings.

  1. Go to iPhone Settings
  2. Scroll down until you find a listing of all your applications on the phone
  3. In this list find Appsheet
  4. Click on Appsheet
  5. In the ‘Allow Appsheet to Access’ section the top selection should be ‘Location’
  6. Click on ‘Location’ and select ‘While Using the App’

If you still have issues after that I guess we can revisit.

3 Likes

Thanks, guys.

I did all of that last night (a couple times) before posting this. I did it again this morning and still nothing. This is what I’m getting. As you can see, Avenza Maps also asked for permission to use GPS services, but theirs actually stuck when I allowed it. My app asks, I allow it, but it doesn’t stick. I can’t think of anything else I can do.!

!

After posting the above, I checked a couple more things.
You can see appsheets isn’t allowed to access GPS but Avenza is.

I also facing the same issues…

Anyone can help?