Greetings, I have 2 Tables (Assets + Check O...

references
(Raymond Hua) #1

Greetings,

I have 2 Tables (Assets + Check Out).

I’ve looked at some examples in the Google+ community and I created a couple actions and a workflow where, when I add a new “Check Out” item, It triggers an data change on the “Assets” Table and sets the Availability column in it to False.

I have a Company Tag column that links the tables together, but i’m not sure if my Referenced Rows Formula is correct because the value didn’t change when I tested it.

SELECT(Assets[Company Tag], [Company Tag] = [_THISROW].[Company Tag])

Any suggestions? Thanks in Advance.

(Philip Garrett) #2

@Raymond_Hua

I tried your Data Change workflow rule and it worked perfectly.

I updated the “Check Out” table record with key “041508800600”. When I did that the Change fired. It set field “Availability” in table “Assets” to “false”.

I presume you must have made a change to fix the problem. At any rate, it is working now.

(Raymond Hua) #3

LOL when I first had it, the spreadsheet and app preview didnt reflect the action, so I was doubting myself.

I did make some UX changes after posting this question yesterday…

idk self-healing code.

THANKS!

(Raymond Hua) #4

It broke again after i added a couple more views.I didnt change the formula nor actions. I had it trigger upon add and updates.

Can you take a look again?

(Philip Garrett) #5

@Raymond_Hua

Action “Check Out Point to Assets” refers to action “Point to Assets>Availability>Set False”. It appears that action “Point to Assets>Availability>Set False” has been renamed to “Availability>Set False” so the referenced action name could not be found.

If you update Action “Check Out Point to Assets” to refer to “Availability>Set False” it should work again.

This uncovered an AppSheet error. We should have been validating the Composite action to ensure that the Referenced Action and Referenced Table were valid. I have added validation for this error.

If testing goes well this change will be released tomorrow afternoon Seattle time.

(Raymond Hua) #6

@Philip_Garrett_Appsh Ahhh I see! My fault, I was cleaning up some terminology and forgot to update the referenced actions.

It works again!

Thanks