"Hangouts no longer supports SMS messaging" ...

(Brady Lovell) #1

“Hangouts no longer supports SMS messaging”

How do I text from a tablet not on a wireless plan?

I am currently using a Galaxy Tab S3 to run my App, and when I go to click on the text message icon, it throws the above mentioned error. I would like to use my Google Voice number to send texts, but I get this error.

Hangouts is not set as the default SMS app either. I do not have the tablet hooked up to my Verizon plan, and am really trying to avoid having to do that so if have any suggestions, they would be greatly appreciated.

Thanks!

(Praveen Seshadri (AppSheet)) #2

@Brian_Sabino and +Gil Littman

— any ideas?

(David Hopkins) #3

If you have a Google Voice account, you can actually still SMS from Hangouts on your tablet. You do have to have your Voice account installed on the tablet and it’s appropriately activated.

(Gil Littman [AppSheet]) #4

@Brady_Lovell That is weird. Is your app texting to a specific number (or a set of hard coded numbers)? Or can the user add numbers? If it’s the first option, a possible workaround would be to send the text message as an email to that number’s carrier. It will be received as a normal text message.

(David Hopkins) #5

Ok… @Brady_Lovell

… Testing complete…

After spending the last 20 mins building a TEST SMS app and sending dozens of SMS messages to myself and my wife… (ROFL) I re read the issue above and realized that that isnt your trouble… LOL

So… I went into my test app and tried to launch the SMS tool to a single number in a list… No Go!

So, I have AT&T for my cellular service and they offer (as does Verizon) an app that send your SMS via your phone over wifi… I can’t get it to work… :wink:

Turns out that I’m in the same boat that you are… I just didn’t realize it. It would appear that all of the texting I do from my tablet is via the AS SMS interface or Hangouts…

I’ll let you know if I find another solution.

(Brady Lovell) #6

@Gil_Littman_AppSheet to a specific number for an individual who is assigned to a particular order.

My database consists of roughly 4000 rows of orders, each order is assigned a driver and a driver phone number. The ‘text’ and ‘call’ actions in the UX work properly every where else I’ve tried, just not on this new tablet for some reason.

(Brady Lovell) #7

@David_Hopkins My tablet seems to have some sort of “lock” , or

security filter, that won’t allow me to set a default SMS app, unless the tablet is on a wireless network. At least that’s the only theory I have as of right now. Almost makes me think rooting it may solve the problem. Although, I haven’t had the need to root an Android device in some time, so I am no expert in that field by any means so I really have no idea.

(Gil Littman [AppSheet]) #8

@Brady_Lovell So it sounds like the workaround I suggested is possible, but defiantly not optimal (since you have to change to behavior of the whole app because of one device). As for rooting, I wouldn’t recommend it unless you are sure you know what you’re doing.

(Brady Lovell) #9

I highly doubt I will root it, unless their is an idiot proof way of doing it, which I’m not sure of as I haven’t researched it yet. This particular tablet is still new to me, so

I’ll keep working on the issue and will update this post if I make any progress. Thanks @Gil_Littman_AppSheet and @David_Hopkins for the help!

(Gil Littman [AppSheet]) #10

@Brady_Lovell You’re welcome. I hope you’ll be able to solve this issue.

(Gil Littman [AppSheet]) #11

If hangouts stopped supporting SMS, you’ll just need to get a different app to handle

your SMSing. AFAIK, the Google Voice app can do it. Install the app and set it to be your your default SMS app, as AppSheet will call the default SMS app when trying to send SMS.

Let me know you managed to solve the issue.

(Brady Lovell) #12

Apparently I can’t set a default SMS from the tablet unless it’s on a wireless plan. At least that’s what they’re telling me at Samsung support. Looking for an alternative method. I really don’t want to hook my tablet up to my wireless provider.

(David Hopkins) #13

@Brady_Lovell I would try getting a free google voice number, and installing Google Voice first. That’s what I use… I’ve never had a tablet with Cellular service.

(Brady Lovell) #14

@David_Hopkins that’s the same thing I did. I bought WiFi model specifically so I didn’t have hook it up to my wireless plan. I downloaded Google Voice, went into my AppSheet app to send a text message, and I got the above mentioned error. When I went to try a find a way to set the Deafault SMS option on the tablet, there wasn’t a way to do it (at least I couldn’t figure it out). So I called Samsung, and the tech support guy said there was no way to set a default SMS app without a wireless plan?

Doesn’t make too much sense to me. I’ve tested Voice and Hangouts from my tablet, and both are working just fine. I don’t know why the connection between AppSheet and Hangouts isn’t working?

Unsure on this one…probably something stupid or easily over looked. Search for an answer continues @Gil_Littman_AppSheet

(David Hopkins) #15

@Brady_Lovell Ok. so you are on the same path that I take… let me hit my tablet… Samsung, wifi only, G’Voice … i’ll test …

(Gil Littman [AppSheet]) #16

@Brady_Lovell What happens if you go to the contacts app on your tablet, and click the text icon next to one of your contacts? Are you able to send the text?

(Brady Lovell) #17

@Gil_Littman_AppSheet No I sure can’t. The phone number is there just like it should be, but no option to send text or call or nothing. Weird. Wonder if it’s something new Samsung is implementing? Not sure how old the Tab S3 is, but I know it’s their newest version. This is their Wi-Fi only model of the Tab S3. All of the functionality of Voice and Hangouts works as it should, which I launch the standalone app. But so far, no way to connect AppSheet, or even the default Contacts that shipped with the tablet.

(Brady Lovell) #18

I wonder if rooting the device will allow me to set the default SMS…