Has anyone seen this error before? It has me ...

(Tim Watts) #1

Has anyone seen this error before? It has me stumped Unable to add/edit/delete row in table ‘Links Request.xlsx’. → The requested row number is 2 but the largest row number in the table is 1. The row you are trying to modify might have been deleted.

This comes up when I am trying to save a report.

(Dinh Nguyen Nguyen) #2

@Tim_Watts Hi Tim, could you give me the following information so I can investigate the problem:

1/ Your account ID 2/ The name of the app 3/ The steps that you took which produced the error

Thank you.

(Dinh Nguyen Nguyen) #3

@Tim_Watts Hi Tim, this error indicates that AppSheet was unable to find the row you were trying to update in the spreadsheet. As the error message suggests, a possible cause is that this row has been deleted. It seems you’re using the row number as the row keys. This means that AppSheet will rely on the row number to find the correct row to update. The row number of the row you were trying to update was 2, but the largest row number that the app could find in the sheet was 1. Could you check the spreadsheet to see if the row is still there?

(Tim Watts) #4

Hi @Harry , the Only problem is that I wasn’t trying to update anything I was entering new information. I have tried regenerating it a couple of times and it still happens. I also get the same error on another table. Both of these were made today.

(Tim Watts) #5

And I am using date/time as my key

(Tim Watts) #6

@Harry

514074 PCYC Hub Any of the new tables I have created today.

Links requests, service providers, contact.

Used on PC, whenever I add a new form and save I am getting the error.

(Dinh Nguyen Nguyen) #7

@Tim_Watts Hi Tim, there was a bug which caused this error whenever new rows were added to an empty table in Excel. I’ve put in a fix for this, which will be released soon. We’re sorry for the disruption caused.

(Jim Davidson) #8

@Tim_Watts The simple solution here is to add a row to the top of the spread sheet. I have had the same issues previously.

(Dinh Nguyen Nguyen) #9

@Jim_Davidson Hi Jim, are you using Excel spreadsheets in OneDrive or Office 365? If so, a fix for this bug has been released so you won’t have to insert a row into the table as a workaround anymore.