Hello Community, I have a WORK FLOW set up t...

(VICTOR VERA) #1

Hello Community,

I have a WORK FLOW set up that is supposed to fire a DATA CHANGE with an ACTION. I look in the logs and every thing looks like its working but its not,

the action is supposed to set a value in a column if the work flow conditions are met.

any solutions? it seems like a bug

(Aleksi Alkio) #2

Have you tried to launch the action directly without Workflow?

(Dinh Nguyen Nguyen) #3

@VICTOR_VERA To help us investigate further, please give us more information about the problem. Specifically, what are the names of the app, the action, and the workflow involved? Also, what are the symptoms of the problem? What is the change that you expect to see when the workflow is triggered? What do you actually see? Have checked to the log to make sure that the workflow was properly triggered (the workflow condition was met and there was no error)?

(VICTOR VERA) #4

@Harry

Thank the team for helping out on this issue we greatly appreciate it.

(Dinh Nguyen Nguyen) #5

@VICTOR_VERA You’re welcome. Glad the problem is fixed :slight_smile:

(VICTOR VERA) #6

@Harry

So the App is Called CALEB, the action is called ROW UPDATED and the work flow is called ROW UPDATED,

I want any update on a row to trigger the ROW UPDATED action for the project schedule table. For this I believe I should use the Work flow. The ROW UPDATED action is supposed to put a color value in the UPDATE NEEDED column.

Nothing happens though.

(Dinh Nguyen Nguyen) #7

@VICTOR_VERA Hi Victor, action “ROW UPDATED” is configured to set the value of column “UPDATE NEEDED” to “RED”. However, this value doesn’t exist in the column’s enum options. Instead of “RED”, could you change the value of the action to “Red” and try again?

(VICTOR VERA) #8

@Harry

Some extra info:

I only use

“Quick Edits”

function to update info in the table

(VICTOR VERA) #9

Thanks @Harry,

I tried your suggestion with no luck.

When I fire the action manually it works fine just how its configured now.

When I try the action as part of a workflow rule, it does not work, yet in the log i cant see any issues or fails.

Again, I only use

“Quick Edits”

function to update info in the table. Can this be part of the issue??? @Harry

(VICTOR VERA) #10

@Aleksi_Alkio YES, and it works fine, when I use the action in a workflow it does not fire. I checked the logs and I cant identify a fail anywhere.

any ideas??

(VICTOR VERA) #11

@Harry

So ive Identified a pattern, Data Change Workflows do not work

in “SMARTSHEETS”.

Is this something you are aware of??

(Dinh Nguyen Nguyen) #12

@VICTOR_VERA Hi Victor, after some investigation, we believe there might be a bug that prevents workflow data change from working with Smartsheet. We are still debugging this and will update you as soon as possible. We apologize for the inconvenience.

(VICTOR VERA) #13

@Harry

Thank you very much for your help