Hello, I am new to AppSheet. I am trying to ...

(Niket) #1

Hello,

I am new to AppSheet. I am trying to add my salesforce sandbox org to appsheet data sources. But every-time i do, i am getting below error -

{“error”:“invalid_grant”,“error_description”:“authentication failure”}

When appsheet redirects to Salesforce, I am replacing login.salesforce with test.salesforce to connect with sandbox. But it does not works. I even tried to use custom domain, but no help.

I am able to connect to production & developer orgs, but not the sandbox org. Can someone please help?

Thank you

(Praveen Seshadri (AppSheet)) #2

Hi, the info in this article may help you … help.appsheet.com - Using Data from Salesforce

Search in it for “sandbox” — you’ll see that there is a different package you need to install in your sandbox. Using Data from Salesforce help.appsheet.com

(Niket) #3

@praveen Thanks Praveen, I have installed sandbox package from the same place, still it doesn’t works.

(Praveen Seshadri (AppSheet)) #4

This is odd. Because if AppSheet gets the information that it is a sandbox instance, it will automatically connect to test.salesforce

endpoints. You will not need to change anything manually. This is why I wonder if the appropriate package has been installed.

(Niket) #5

@praveen

Thanks Praveen, I appreciate your responses. I agree appsheet should automatically detect sandbox org. But somehow its not connecting.

To ensure I am not making mistake mistake, I created a fresh sandbox & installed the sandbox appsheet package to it. Then I tried to connect it with app sheet, but no luck. Same error. Not sure whats going wrong.

Thanks