Hello, I have ref`s to a main table. Any ide...

(Aktar As) #1

Hello,

I have ref`s to a main table. Any idea how i can fix it so they get added 1, 2, 3 ?.Its added that way in the form, but changes when saved.

Thank you :slight_smile:

(Steven Coile) #2

Create a Table view of position Ref for the Soverom data set with the desired formatting (including sort order). Note that there may already be a system-generated one with the _Inline suffix in the name that you can use.

(Aktar As) #3

amazing, i love these new discoveries, makes everything so much easier ! Thank you!

(Aktar As) #4

One thing… when i put it in table it sorts beautifully, but when i tried that “Detail” then it goes back to 2, 1 , 3. Even when i use the sort function that worked in table view… :confused: Any idea why ?

Thank you!

(Steven Coile) #5

@Aktar_As In the Detail view for the same data set, set the row sorting order to match that in the Table view. If I understand your problem correctly…

(Aktar As) #6

Sorry bad explination. I made a ref view on the “soverom” table, and then on that i put sorting on “SoveromID”. When i had that ref view in table view, then it sorted correctly. But when i tried the ref Soverom view in detail view, it no longer cared for the sorting i said. the order then went back to 2,1,3…

(Steven Coile) #7

@Aktar_As You can also create a Ref view for the Detail view. In that Detail view you can also choose the sorting order.

(Aktar As) #8

I deleted the entry and made a new one… seems to work now, might of just have glitched abit. :slight_smile: Hopefully it keeps working! Thank you Steven!

Update: Nevermind, it sorted it wrong again now

(Aktar As) #9

Do you mean a ref view for the ref view? … Because it works when i use table view on the refview to the “soverom” data. But not when i use detail view to the “soverom” data.

(Steven Coile) #10

@Aktar_As To sort rows of a table, you need to configure sorting in every view that displays rows from the table, notably the table and detail views. To affect the sorting of rows that appear in the inline tables in detail views, you need a table-type view in the ref position for the data set containing the rows you want to sort, the Sovorom table in this case.

(Aktar As) #11

Thanks for respone… Yeah , i think this must be a bug, because it sorts correctly with deck view, table view, galleryview, but not detail view… Same sorting settings…