Help, I have a problem! Last night (NZ local ...

(William Stewart) #1

Help, I have a problem! Last night (NZ local time 12/10/2018 20:00) I had a version of my app working well. I made some changes this morning…Now I can’t seem to restore a working version. It doesn’t help that the timestamp on the version history doesn’t seem to be local time… Can any one suggest anything? I had just got my webhook API working and since making my changes it has stopped working, and restoring older versions hasn’t worked yet… I have made a bit of a mess of version history in trying to restore. Thanks

(William Stewart) #2

Getting this Rest API error: Error: Value ‘’ in field ‘Date’ in table ‘RentReceived’ cannot be converted to type ‘Date’.",

#3

Hi @William_Stewart have a look below at @Fabian post maybe it is the same error?

(William Stewart) #4

@Philip_Garrett_Appsh This part of it is working well! always more to refine though. Thanks for your input

(Philip Garrett) #5

@William_Stewart

See if passing the date in US date format (i.e. mm/dd/yyyy) fixes the problem.

I suspect that there is no problem with your app. The day just changed in NZ. If you are passing 13 and it is showing up in the month field, the date won’t parse.

(William Stewart) #6

@Philip_Garrett_Appsh I was wondering that but I had changed the sheets format to us date thinking it would resolve it. Can I instead change the locale in the Json body to en-UK? I tried Australia but that didn’t seem to work.

(Philip Garrett) #7

@William_Stewart

What is the format of the date you are including in the JSON body? Is it “DD/MM/YYYY” or "“MM/DD/YYYY”?

(William Stewart) #8

@Philip_Garrett_Appsh the date it is copying is dd/mm/yyyy and locale of sheets and appsheet set to Australia. In Json it is set to US as it wouldn’t accept australia

(Philip Garrett) #9

@William_Stewart

And is that working? By that I mean, is the update performed correctly?

If not, please provide: 1. Your account id 2. The app name 3. The exact error message. 4. The exact steps to reproduce the problem.

(William Stewart) #10

@Philip_Garrett_Appsh

I think you are probably right, that yesterday I got lucky with the date being 12 (i.e. highest month possible) and so it updated great. I subsequently made several changes, and then went to test to discover it no longer worked. I assumed it was because of all my changes…Now I have made a mess of records trying to recover a working app, not realising that the date format was likely the culprit. 1. 708906 2. Property Management App 3. {

“Operation”: “REST API invoke”,

“AppId”: “f30c709c-224b-43f2-90ff-2fcd917618f2”,

“TableName”: “RentReceived”,

“Action”: “Add”,

“RestActionType”: 1,

“DataAction”: “App: add a new row (not a row-level action)”,

“locale”: “en-US”,

“location”: “”,

“runAsUserEmail”: “”,

“timezone”: “New Zealand Standard Time”,

“tzOffset”: “-780”,

“userId”: 708906,

“Rows”: 1,

“Performance”: “{“Version”:1,“Time”:“00:00:00.0616918”,“PerformanceTimingRoot”:{“Mid”:317,“Timer”:{“Time”:“00:00:00.0616918”},“Children”:[{“Mid”:62,“Timer”:{“Time”:“00:00:00.0551892”}}]}}”,

“Result”: “Failure”,

“ResultError”: “Error: Value ‘’ in field ‘Date’ in table ‘RentReceived’ cannot be converted to type ‘Date’.”,

“RecordType”: “Stop” } 4. Invoking bulk action Rent Received or Rent Not Received

(William Stewart) #11

@Philip_Garrett_Appsh Trial and error as there is no list of accepted Locale descriptions. I changed Locale to en-AU. Now working correctly again

(Philip Garrett) #12

@William_Stewart

Glad to hear that issue is resolved. Is everything working as you intended now?