Help with Enum data type using Percent as base type

Hello all,

I have a strange thing happening and can’t figure it out. Need some help. I have a Column Type Enum that has some choices for values that need to be presented as Percent, so I have selected Percent as the Base Type.

The issue is that some of the values do not show up as selected when viewing the record in Form View and other values do show up as selected. All other functionality using these values is working as expected.

Attached images of what it looks like in Form View and the corresponding screenshot of the data in the table showing the values of the field.

Thanks in advance!


Everything looks fine to me. What exactly is the issue?

Hi,

In the image in the middle, you can see that in from view the buttons appear selected according to the values in those fields already recorded for that record, but on the other images some values don’t show up as selected even though they are already populated just like the example in the middle.

On the left side, “Retención ISR” should have the 2.00% button appear as selected just as the 100% Retención ITBIS is.

1 Like

Ahh. How were the values “already recorded”? What are the actual values in those cells (not the formatted/display value) ?

1 Like

Hi,

The values were recorded using that same from. The image is just the form reopened after having saved it. The values in the cells are presented as 2%, 100%, 0%…

Even if I remove all formatting from the cells and erase the values, when I record them again using the form, they show up again as 2%, 100%, etc. (as the values within the cell, not the display of them) and the behavior stays the same. :frowning:

That’s odd. Could be a bug.

Let’s try a couple other things though:

  1. Make all of your Enum selections the full 3-digit representation. So 1.00, 0.20, etc.
  2. In your GSheet, select the values and format them as “plain text”, then report back what the actual data values are in both the working and not-working cases.
  3. You could try to use Percent column type, instead of Enum, then provide the following expression in Valid_If or Suggested Values
    LIST( 0.00 , 0.02 , 0.10 )
1 Like

I tried options 1 and 2 from your suggestions and still had the same issue.

Tried number 3 and that works perfectly. Looks like it might be a bug. Anyways, thanks a lot for the help!

2 Likes