Sorry I wasn’t clear, I probably did not give enough context at first.
Here is a more explained context.
My app is somewhat a basic inventory app.
Its particularity is that some of the products can be made of various other products, hence the example with the shower kit, with its 3 panes and its 2 taps.
In order to proceed to stock in and stock out, I must be able to say “ok, here are 15 window panes, 5 shower kits, and 36 taps”.
Now, in order to achieve the calculation of my inventory stock, I must be able to say “for single elements (i.e. no kits), there are currently 20 panes and 30 taps”, no matter how many shower kits I physically have.
To do so, I used a table, which is here Assembly_Parts, and there are 2 columns with type Ref, all relating to the Products Table, + 1 column quantity which says how many “components” product are part of the “part of” product. The vocabulary may be incorrect for understanding purpose ?
In order to make the my own understanding clearer, I just renamed the “product” from the first picture into “component_product”, but nothing else changed.
My Assembly_Part table may be not the good idea or the good structure for it, that what came to my mind in order to solve this “assembly/composition” request. This is why I’m open to suggestions as well.
I hope it sounds clearer now, let me know if you need further informations