Help with static image from Google drive

I need help with the static image from Google drive.

I can’t seem to get it right.

When I follow the instructions below, the URL I get doesn’t appear in the same format as below.

I did try and copy and paste some of the info from the Shareable link I got but none of the attempts I used worked.
Appsheet help intructions:

"* Google Drive: Viewing an image on Google Drive shows your image on a web page that hosts an image, but the URL of the web page will not work as a link to your image. To get the correct URL for an image hosted on Drive, first use the “get shareable link” option in Share settings. This provides a URL like https://drive.google.com/open?id={fileID} . This still leads to a web page hosting your image, not the image itself, but it provides the file ID you need to create the final image link: https://drive.google.com/uc?export=view&id={fileID}"

This is the link I got when I requested get Shareable link.

https://drive.google.com/file/d /1q40YBeo78mQuzF4iBf-sZKZJ3Jqwq-U4/view?usp=sharing”

Note: I added a “space” after “/d” so that you can see the link otherwise it shows up as the image name.

Which part of this should be copied and pasted in to the final image link?

Please try as below

1 Like

Thank you. And do I add this as a Show column with Image selected?

I tried this https://drive.google.com/uc?export=view&id=1q40YBeo78mQuzF4iBf-sZKZJ3Jqwq-U4 and got this error.

Arithmetic expression ‘(“https:”/“drive.google.com”)’ has inputs of an invalid type ‘Unknown’

If you are using it in show column please include it in double quoteshttps://drive.google.com/uc?export=view&id=1q40YBeo78mQuzF4iBf-sZKZJ3Jqwq-U4

1 Like

Thanks, it just shows a thumbnail image where the image is supposed to be in the editor. Is that normal behaviour? It is a PNG file should it be a Jpg maybe?

Could you elaborate what you mean by this, especially " the image is supposed to be in the editor"?

Edit:

That should be fine.

1 Like

This is what I meant

1 Like

It sounds that there is still something incorrect in your column setting. Could you share the screenshot.

1 Like

1 Like

A few possibilities are

  1. In Google drive the sharabale setting for the file is NOT set to “Anyone on the internet with this link can view” Please set it accordingly.

  2. There is some issue in file ID, missing double quotes on the other side of the expression or some space while copying the URL

I believe you may need to do some such trouibleshooting. I retested it at my end and it works perfectly.

1 Like

It took a very long time to show up. I resynched it shows the thumbnail and then after a couple of minutes it loaded.

The file size is 767kb. Should it take so long?

I am unsure about image file size part. I tested it with a 3KB and 60 KB PNGs. I agree that first time loading was slower when I tested as well. But subsequent loadings are faster.

However, I think the Pixel size needs to be 600 X 600.

Please take a look at the below articles just in case you have not already.

Images or files that do not load | AppSheet Help Center

1 Like

Thank you for your help

2 Likes