Hey guys, I have one table where the "require...

(Hyman van Zyl) #1

Hey guys, I have one table where the “required” function doesnt want to work. I can select it and in the properties view of the column it shows that it is activated but it just doesnt work. Ive tried with several columns in the table as well as the “Requred_If” function but it doesnt work. All other tables are fine. Ive also checked my sheet for any funy formatting and cleared it all. Any idea what can be causing this and how to solve? Thanks lots, Hyman

(Dinh Nguyen Nguyen) #2

@Hyman_van_Zyl1 In table Organizations, some of the required columns have the following Required_If condition:

[Activate Required]=“Yes”

This means that these columns will only be required if the value of column “Activate Required” is “Yes”. This column in turn is an enum with 2 options: “Yes” and “No”. The initial value of this column is “No”, which means that when the form is first open, any column that has the above Required_If condition will not be required. Only when the value of column “Activate Required” is changed to “Yes” will the other columns be required.

(Dinh Nguyen Nguyen) #3

@Hyman_van_Zyl1 Hi, could you explain how the “required” setting does not work for you? An example would be best. Also, is there anything special about the affected column? Is it hidden because of a Show_If? Does it have a drop down list that is empty because of a Valid_If? Could you give us the names of all the relevant app, tables, and columns?

(Hyman van Zyl) #4

@Harry

(Dinh Nguyen Nguyen) #5

@Hyman_van_Zyl1 Could you give us a step-by-step description of how to reproduce the problem? Specifically, what are the exact steps that we have to take in order to be able to set “Activate Required” to “Yes”?

I’m asking this because I noticed that the app only uses slices of the affected table, and it seems that all of these slices do not include column “Activate Required”.

(Hyman van Zyl) #6

@Harry +Steve Coile Hey Guys, yho, thanks again for the diligence.

I was also thinking to redi the table if you guys cant come up with an alternative. Dinh, “Activate Required” can only be accessed when no proposal or progress report has been created yet. An alternative but same looking action then takes you to the slide where “Activate Required” is included and to a form view where the user can then set it to “Yes” to ensure all fields are completed as to populate the proposal template. I did not want to force the user to do this from the start when adding organization or a project as it is a lot thats needed for the proposal but not for the rest of the app like project planning and management. Merry Christmas and thanks. Hyman

(Aleksi Alkio) #7

@Hyman_van_Zyl1 Is it possible that you have a Show type field (Page header) which is hidden?

(Hyman van Zyl) #8

@Aleksi_Alkio @Harry+Steve Coile Hey Aleksi, yeahi!! that solved it. I un-hid all the show columns in the table and now the

required function is working. Thank lots. Will experiment with which show column could be hidden. Looks like you recommend as long as page header stay unhidden.

If I may ask one more question? I am using this formula to select only tasks which were completed after previous report up to the date of this report. It is used in the report table.

=SELECT(Tasks[EntryID],AND([Project]=[_THISROW].[Project],[Done]=”Done”,[Date Done]>[Latest Previous Date],[Date Done]<=[Date]))

I am using a changetimestamp to register when someone selects task as done - [Date Done]. So I also made the report date [Date] and [latest previous date] a DateTime column.

The problem is that it doesnt select the done tasks very accurately. I see that google sheets show the datetime without pm/am and appsheet with.

Could this be the problem? I cant find a way to make it similar. The locale is the same - United Kingdom. Any advice? Thanks lots Hyman

(Aleksi Alkio) #9

It seems that this is solved in another post. For others… the problem was the missing [_THISROW]. The end of the expression should have… [Date Done]<=[_THISROW].[Date]

(Hyman van Zyl) #10

@Hyman_van_Zyl1 hi, it does not work in the way that it does not show the * symbol and I can save the form even though

the columns which I selected to be required, is still blank. It happens with all the columns of the one table. The other tables are fine. Some columns in this table are only text, some enum. The app is called Project Management 5 and the table that has the problem is called Organization. Thanks lots, Hyman

(Steven Coile) #11

Try making a trivial change to the problem table and click Save & verify data instead of SAVE.

(Steven Coile) #12

Also, can you make any changes to the problem table’s configuration that takes effect? Are there other problems with the table, or just the column requirements? For instance, can you set a Valid_If property and does it work properly? Or change the type of a column?

(Steven Coile) #13

Are any messages displayed in Info > Errors?

(Steven Coile) #14

As @Harry asked, does the problem column have a Valid_If property? If so, can its expression ever produce an empty list? Could you share the Valid_If expression with us?

(Hyman van Zyl) #15

+Steve Coile @Harry Hey guys, thanks so much for all the feedback. It was getting late this side so I first had a sleep.

I set up the “Activate Required” column. This allows the user to only have to complete all columns at a later stage. But even when you set it to “Yes” the columns does not change to required. Same as when you select required in the data column property. The “Activate Required” function works perfectly in other tables though. I made trivial changes and did the “save and verify”,

the

change I made works but the problem continue. No errors in info. There is some valid_if statements in the table that works perfectly.

I did earlier set up some row and cell protection conditions in the google sheet but removed it afterwards. This is the only thing I can think which is now confusing the app because I only did it for this table. Any other suggestions? Thanks Hyman

(Steven Coile) #16

I’m stumped! I don’t know what else to look at. Were it me, I’d probably next try to recreate the entire worksheet and table (as new, separate worksheet and table, keeping the originals), step-by-step, to see where if at all the problem develops. I’m sorry I can’t offer anything simpler. :frowning: