Hi all!, I was under the impression that what...

(Malaka Jayawardene) #1

Hi all!, I was under the impression that what ever the column (physical or virtual) we create in a table, it can always be made visible in the “Detail view” by going in to UX>Table’s_Detail view’s view order and selecting that specific virtual column or physical column (all the while changing its order), and of course that virtual or physical column can be hidden from the “Form view” by ticking the “Hidden” option in Data>Column. This is what I thought. But apparently this doesn’t work for “SHOW” type columns is it? “Show” type columns do not appear if you make it “hidden” eventhough you choose it to be visible in the Detail view before making it hidden in the form view. This doesn’t apply for other column types. In reason why this happens?

(Reza Raoofi) #2

I was under impression once you mark a column as hidden in column structure (i.e. Data > Columns) it would be hidden in all views; do you mean you have tested and made a column hidden and then you were able to display it in Detail View? That column selection/order in views should be on a higher level and applied only for visible columns that are not hidden in column structure.

(Steven Coile) #3

The HIDDEN toggle applies to all display of the column. The column’s Show_If property can be used to hide the column selectively with an expression that uses the CONTEXT() function.

(Malaka Jayawardene) #4

Thank you for your input Steve. If we made the column order through the UX>Table’s Detail view’s Column Order, and then proceed to hide that column through Data>Column, the column gets hidden in the Form view, but still it’s visible in the Detail view. Yes, I have tested that. But it doesn’t work for Show Type Columns though, that’s what I was on about. Anyhow like you’ve mentioned, I used the CONTEXT() function in the Show_If property to get what I wanted. Thank you very much for your help.

(Steven Coile) #5

Also review the following settings in UX > Options: FORMS > Apply show-if constraints universally and DETAIL VIEW > Include Show columns in detail views.