Hi community, column width is driving me craz...

(Luigi Binaghi) #1

Hi community, column width is driving me crazy

I already have set columns to wide and saved and verified data, column has like 100ish rows but still I cant figure how to have a column wide enough to contain my data and the empty screen is huge Could you help? I dont want to be forced to split my data in multiple columns as a workaround

Ty

(Reza Raoofi) #2

As far as I know, Save and verify data is supposed to adjust columns width according the data length in table! @Adam_Stone_AppSheet

(Praveen Seshadri (AppSheet)) #3

Save & Verify will look at your actual data and record min/max lengths of data. That gets used in computing column widths.

(Aleksi Alkio) #4

@Luigi_Binaghi There has to be something wrong in your model. I made a test with a table view where I set only one text type field. That field contains long string and it’s showing the whole string. Do you have more than one column in your table view?

(Kane Group) #5

I’m having the same problem. Save and verify does not change column width. I have a column called Task in 3 different tables and the table view seems to pick a random width for each column.

(Luigi Binaghi) #6

@Aleksi_Alkio Hi Aleksi. Yes there are some more columns (uniqueid(), amount, …) but they are all “hidden” in the table view you see above. Actually that view was based on a slice and I just made a test with a new table view based on the complete table to see if there was the problem but the outcome is sadly the same

(Luigi Binaghi) #7

@Aleksi_Alkio I think I nailed it. Culprit is

the “use horizontal scrolling” flag. As soon as you disable horizontal scrolling column width behaves as expected (see attachment). Now the question … can we have both large columns and horizontal scrolling? :slight_smile:

(Aleksi Alkio) #8

@Morgan_Dixon_AppShee Thoughts for this?

(Kane Group) #9

Yes, that’s the problem!