Hi everyone! Can anyone help me, please? I'...

(Fabio Oliveira) #1

Hi everyone!

Can anyone help me, please?

I’ve built an app that was running nice and smoothly both on the browser and the mobile app.

Now, all of a sudden, for some reason there is a field that simply won’t appear in any of the views, even though it’s set as required and not hidden or anything like that.

I’ve also checked the slices I am working with, and they are included there.

I have already tried regenerating columns, but no success.

Any ideas?

Many thanks!

(Aleksi Alkio) #2

What is the column type and does that column contains any data in your sheet already?

(Fabio Oliveira) #3

Hi Aleksi,

Thanks for your help!

I’m sorry, I forgot to say that it doesn’t appear when I am submitting/adding a new entry. When I see saved entries it does appear (when they contain some data).

It’s a ENUM column using a ValidIf formula.

(Praveen Seshadri (AppSheet)) #4

Most likely the Valid_If condition is such that there are no valid values. If so, it will not show in the form because there is nothing you could enter that would satisfy it.

In short, check the Valid_If formula

(Fabio Oliveira) #5

@praveen Hi Praveen. Many thanks! It was indeed the Valid_iF formula. I fixed that and now it works perfectly!