Hi everyone, i´ve been having a problem tryin...

(Sebastian Avila) #1

Hi everyone, i´ve been having a problem trying to set the currency

From :

$247.875,44 To:

$247,875.44

In the Tables i have Data locale option set in Spanish (Mexico), i also have it this way in my google spreadsheets but it´s still showing that strange format.

Any ideas on what can i do to fix this?

(Philip Garrett) #2

+Sebastián Ávila

Can you provide: 1. Account id 2. App Name 3. Table name 4. Field name

Where exactly is the value being displayed incorrectly? Is it on the client device or in workflow?

(Sebastian Avila) #3

The values are being displayed in the app in general.

My account ID is: 627275 App.name: COBRANZA-GCDMX Table name: DEPENDENCIAS, PLANPAGOS, PAGOS, FONDOS Field name: IMPORTE TOTAL, PAGADO TOTAL, PENDIENTE TOTAL, IMPORTE TOTAL A PAGAR, PAGADO, PENDIENTE DE PAGO (across all tables) Translate

(Philip Garrett) #4

+Sebastián Ávila

Can you clarify two points?

  1. Are you saying that the values are being displayed incorrectly in the app as opposed to in workflow rules? 2. If the values are being displayed incorrectly in the app, is the app being run in a desktop browser, on an iOS device, or on an Android device?
(Sebastian Avila) #5

@Philip_Garrett_Appsh 1. Yes and i removed the workflow because it was causing troble 2. i´m using the app in the browser and that´s where i´ve seen the valeues being dispalyed incorrectly

(Philip Garrett) #6

+Sebastián Ávila

If you are running your app in the browser, the browser’s language setting controls how data values are displayed. This include prices, decimals, date, times, etc.

I am going to assume that you are running Chrome on Windows.

Change the language of your Chrome browser (Windows & Chromebook only) You can set Chrome to show all settings and menus in the language you want. This option is only available on Windows and Chromebook computers.

On Mac or Linux? Chrome will automatically display in the default system language for your computer.

On your computer, open Chrome. At the top right, click More More and then Settings. At the bottom, click Advanced. Under “Languages,” click Language. Next to the language you’d like to use, click More More. If the language isn’t listed, add it by clicking Add languages. Click Display Google Chrome in this language or Display Chrome OS in this language.

This option is only available on Windows and Chromebook computers. Restart Chrome to apply the changes.

(Philip Garrett) #7

+Sebastián Ávila

I have added an article explaining this.

See help.appsheet.com - Apps Using Prices, Percents, and Decimals

Apps Using Prices, Percents, and Decimals help.appsheet.com

(Sebastian Avila) #8

@Philip_Garrett_Appsh It´s fixed, thank you for your help.

(Philip Garrett) #9

+Sebastián Ávila

Glad to hear that worked.