Hi .. First of all, thank you for such a grea...

(net sites) #1

Hi … First of all, thank you for such a great programming effort and lovley visulisations in appsheet.

My issue is that the app worked correctly updating or deleting data in the app to the spreadsheet, until I opened the spreadsheet in my google drive and I just expanded and contracted some columns, then it didn’t capture any data changes in the spreadsheet, even after I regenerated all the columns in the app to

Why? … and what is the solution for it?

I had to contract and expand some columns because they didn’ appear in the app (taple forme) … 3 columns apeared and the 3rd one took along space (even I chose Narrow field from the options in the app) Also … why? and what is the solution?

That is how one problem led to another So Please help me with it … to get my app look great and the more important, to find my data in my spreadsheet, to copy it later and edit when I need that in a different styles, with out any data loss.

Thank you in advanced :blush:

(Aleksi Alkio) #2

If you open the editor, do you see the same column structure than in your spreadsheet? Is the amount of columns the same?

(net sites) #3

Yes … it’s the same structure and the amount of columns

(Aleksi Alkio) #4

For the 1st problem… would you please describe step by step how you received this issue, thanks.

(net sites) #5

After I uploaded the spreadsheet (contains 5 sheets) to the google drive … and make the app with appsheet, andAfter I finished formating my tables and UX… etc I started adding data to the app… and when I opened the spreadsheet from google drive … it was all there (data inputs & formulas). But … when I just changed the columns width and exit google drive after saving the spreadsheet … I made some changes and adds from the app … and then went back to spreadsheet … the new entries weren’t there … just the old ones That’s it … and to be sure I tried another spreadsheet and a different app that was working … so I opened the spreadsheet from google drive and repeated what I did (JUST CHANGING THE COLUMNS WIDTH … NOT ANYTHING ELSE) and the same problem occured.

:sweat::sweat:

(net sites) #6

Guess what … when I opened the spreadsheet with google sheets … it showed me every thing i changed or added …

The problem is with excel file viewing from google drive … maybe !!!

(Aleksi Alkio) #7

Okay… when you used the xls from the Drive, did you see all data in your app? You just didn’t see the data in the spreadsheet?

(net sites) #8

That’s right … i didn’t see the data, and still they aren’t there … but when i opened it with google sheet it showed up every thing So … they are actually there but the normally previewer in google drive doesn’t doing well … for that i tried in the top page option (open with google sheet) … then every thing came up (inputs data & calculated data)

There is something mysterious with it!!! :confused: